Closed Bug 1204149 Opened 5 years ago Closed 5 years ago

[e10s] Using Fullscreen API when Firefox is in the Fullscreen Mode makes the chrome confused

Categories

(Firefox :: General, defect)

43 Branch
Unspecified
Windows
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 43
Tracking Status
e10s + ---
firefox43 --- fixed

People

(Reporter: verdi, Assigned: xidorn)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

STR on Windows
1. Make Firefox full screen (F11)
2. Make some content (youtube video) full screen
3. Wait for the full screen notification to go away
4. Mouse to the top of the screen

Result: The Firefox title bar is displayed but the full screen notice is not.

Expected result: The full screen notice should be triggered (in addition to the Fx title bar) like it is when Firefox is in windowed mode.
Example at :35 seconds people.mozilla.org/~mverdi/projects/fullscreen/windows-fullscreen.m4v
Summary: When Firefox and content are full screen, mousing to the top does not trigger full screen notification on Windows → [e10s] Using Fullscreen API when Firefox is in the Fullscreen Mode makes the chrome confused
Duplicate of this bug: 1204151
Blocks: 1121280
It is a regression on 43.
Keywords: regression
It is likely a regression of bug 1196163.
Blocks: 1196163
Bug 1204149 - Fix entering DOM fullscreen in fullscreen mode for e10s.
Attachment #8662196 - Flags: review?(bugs)
Although there seems to be a perm-fail on JP test on Linux debug builds, I really don't believe that relates to this patch...
Attachment #8662196 - Flags: review?(bugs) → review+
Assignee: nobody → quanxunzhen
https://hg.mozilla.org/mozilla-central/rev/28082ed69e66
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
You need to log in before you can comment on or make changes to this bug.