Mouse over/out not working in XML namespace

VERIFIED INVALID

Status

()

P3
normal
VERIFIED INVALID
20 years ago
19 years ago

People

(Reporter: christinehoff4, Assigned: nisheeth_mozilla)

Tracking

Trunk
All
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(9 attachments)

(Reporter)

Description

20 years ago
Using 8/16 Apprunner on Win 95, Win NT, Win 98, Mac8.5 and Linux Red Hat 6.0.

Save attached XML file and two images to your local machine. Here is the XML
code if file cannot be downloaded:

<?xml version="1.0"?>
<doc>
<one xmlns:html="http://www.w3.org/TR/REC-html40">
<html:p style="border: solid red" onMouseover="if (document.images)
             document.images.menu.src='leopard_cat.jpg'"
	onMouseout="if (document.images)
document.images.menu.src='calanque.jpg'">
Mousing over this paragraph box should flip image of water to image of cat.
Mousing outside of the paragraph box should flip image back to water.
</html:p>
<html:img src="calanque.jpg" alt="water">
</html:img>
</one>
</doc>

Expected result: Mousing over the paragraph box should flip 'water' image to
'cat' image. Mousing outside of the paragraph box should flip 'cat'image back
to 'water' image

Actual result: Mouse over/out not working (across platform). This event handling
works as an HTML doc.
(Reporter)

Comment 1

20 years ago
Created attachment 1281 [details]
XML file to demonstrate problem
(Reporter)

Comment 2

20 years ago
Created attachment 1282 [details]
image to go with XML doc
(Reporter)

Comment 3

20 years ago
Created attachment 1283 [details]
image to go with XML doc
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

19 years ago
*** This bug has been marked as a duplicate of 12433 ***
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

19 years ago
Verified dup of #12433
(Reporter)

Updated

19 years ago
Status: VERIFIED → REOPENED
(Reporter)

Comment 6

19 years ago
This bug was marked a duplicate of 12433 which was resolved 9/2. However, this
is still a bug. I am reopening this and providing a revised test case.
(Reporter)

Updated

19 years ago
Resolution: DUPLICATE → ---
(Reporter)

Comment 7

19 years ago
Created attachment 2594 [details]
Test case to demonstrate problem
(Reporter)

Comment 8

19 years ago
Created attachment 2595 [details]
image to go with test case
(Reporter)

Comment 9

19 years ago
Created attachment 2596 [details]
image to go with testcase
(Assignee)

Updated

19 years ago
Status: REOPENED → ASSIGNED
Target Milestone: M13
(Assignee)

Comment 10

19 years ago
Accepting bug and setting milestone to M13...
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → INVALID
(Assignee)

Comment 11

19 years ago
There is no event propagation problem here.  The event handler attributes on the
anchor element need to be all lowercase.  I'm attaching a slightly modified test
case to show that events fire properly when the attributes are lowercased.

To verify:

- Save test.xml, calanque.jpg, villefranche1.jpg into a local directory.
- Load test.xml.
- Mouse over and out of the image.
- You will see messages printed out to the console as you mouse over and out of
the image.

Marking invalid.
(Assignee)

Comment 12

19 years ago
Created attachment 4254 [details]
test.xml
(Assignee)

Comment 13

19 years ago
Created attachment 4255 [details]
calanque.jpg
(Assignee)

Comment 14

19 years ago
Created attachment 4256 [details]
villefranche1.jpg
(Reporter)

Comment 15

19 years ago
Verified invalid
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.