Add-on homepage link is not opened in browser

RESOLVED DUPLICATE of bug 1042280

Status

RESOLVED DUPLICATE of bug 1042280
3 years ago
2 months ago

People

(Reporter: post+mozilla, Unassigned)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0 Iceweasel/40.0.3
Build ID: 20150831023214

Steps to reproduce:

* Install some add-on that has a "Homepage" link in its about data
* Click that link in the add-on information


Actual results:

The add-on homepage as opened in Thunderbird.


Expected results:

The add-on homepage should be opened in my default browser. Thunderbird knows how to launch that browser and does so correctly when I click a link in a mail.

There's not even a way to copy the URL. I literally have to remember the URL and type it into my browser's address bar...

At the very least, the homepage link context menu should get the "Open in Browser" entry that links on websites get. But, really, the link should just be opened in a browser. Thunderbird is not for visiting websites.
There's a pref to open http or https URL's in Thunderbird or in the browser. Go to Tools -> Options -> Advanced -> General -> Config Editor, search for the pref network.protocol-handler.expose.http and toggle it to false. Now http-links will be opened in your browser...
(Reporter)

Comment 2

3 years ago
Indeed, that works. Now I wonder why it is not the default.

Updated

2 years ago
Component: Untriaged → General

Comment 3

10 months ago
(In reply to Onno Ekker [:nONoNonO UTC+1] from comment #1)
> There's a pref to open http or https URL's in Thunderbird or in the browser.
> Go to Tools -> Options -> Advanced -> General -> Config Editor, search for
> the pref network.protocol-handler.expose.http and toggle it to false. Now
> http-links will be opened in your browser...

bug 1042280 suggests this doesn't work
When I toggle the pref network.protocol-handler.expose.https to false, the homepage opens in the browser.
When I also toggle the pref network.protocol-handler.warn-external.https to true, I get a popup to choose browser and the homepage opens correctly in that browser. If I choose to remember the browser, the next click on the homepage link opens correctly in the browser too, so I can't reproduce the behavior of bug 1042280.

When the pref network.protocol-handler.expose.https is set to true (default) however, the homepage doesn't open at all and there's an error in the errorconsole:

NS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN: Cannot modify properties of a WrappedNative  contentAreaUtils.js:1234
	openURL chrome://global/content/contentAreaUtils.js:1234:7
	loadHomepage chrome://mozapps/content/extensions/about.js:104:3
	onclick chrome://mozapps/content/extensions/about.xul:1:26
	doCommand chrome://mozapps/content/extensions/extensions.js:1202:11
	doCommand chrome://mozapps/content/extensions/extensions.js:1522:5
	initialize/< chrome://mozapps/content/extensions/extensions.js:136:5

This happens in Thunderbird 60.0a1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1042280
Component: General → Add-Ons: General
You need to log in before you can comment on or make changes to this bug.