Closed Bug 1204343 Opened 6 years ago Closed 6 years ago

accept call button: Part with text and camera has different size (is higher) than camera button and cancel button

Categories

(Hello (Loop) :: Client, defect, P2)

defect

Tracking

(firefox42 unaffected, firefox43+ fixed, firefox44 fixed)

RESOLVED FIXED
mozilla44
Iteration:
44.1 - Oct 5
Tracking Status
firefox42 --- unaffected
firefox43 + fixed
firefox44 --- fixed

People

(Reporter: aryx, Assigned: standard8)

Details

(Keywords: polish, regression, Whiteboard: [ux defect])

Attachments

(2 files)

Attached image screenshot of issue
Firefox Nightly 43.0a1 20150913 on Windows 8.1

The button to accept a call has a part with text and camera that is higher than camera button on the right and the cancel button on the left.

They have the same height in Firefox Aurora 42.0a2 20150913 on the same machine.

Device pixel ratio is 1.25 on the machine.
[Tracking Requested - why for this release]: Ugly regression.
Rank: 24
Priority: -- → P2
Whiteboard: [ux defect]
Assignee: nobody → standard8
This isn't ideal css, but should hopefully fix the regression enough for 43.
Attachment #8668608 - Flags: review?(mdeboer)
Comment on attachment 8668608 [details] [diff] [review]
Loop's accept call buttons has different heights and looks strange.

Review of attachment 8668608 [details] [diff] [review]:
-----------------------------------------------------------------

Hmmkay, accepting the 'hack'.
Attachment #8668608 - Flags: review?(mdeboer) → review+
https://hg.mozilla.org/mozilla-central/rev/d5f73661541a
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Mark, can you request uplift for this? Looks like you want it on 43.
Flags: needinfo?(standard8)
Yep, working on it. We had a bunch and I'd only got through some of them yesterday.
Flags: needinfo?(standard8)
Comment on attachment 8668608 [details] [diff] [review]
Loop's accept call buttons has different heights and looks strange.

Approval Request Comment
[Feature/regressing bug #]: Visual refresh work. Not sure exactly which bug regressed it.
[User impact if declined]: Direct call accept button looks weird due to differing heights
[Describe test coverage new/current, TreeHerder]: n/a
[Risks and why]: small css change only
[String/UUID change made/needed]: none
Attachment #8668608 - Flags: approval-mozilla-aurora?
Comment on attachment 8668608 [details] [diff] [review]
Loop's accept call buttons has different heights and looks strange.

OK to uplift to aurora, minor css change.
Attachment #8668608 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Iteration: --- → 44.1 - Oct 5
You need to log in before you can comment on or make changes to this bug.