[Email] Email logs out automatically after reboot.

VERIFIED DUPLICATE of bug 1204113

Status

Firefox OS
Gaia::E-Mail
VERIFIED DUPLICATE of bug 1204113
2 years ago
2 years ago

People

(Reporter: Jessica, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [2.5-aries-test-run-2])

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8660628 [details]
logcat_1436.txt

[1.Description]:
[Flame KK v2.5] [Aries KK v2.5][Email] Log in an Email account. After about 30s, reboot the device. Then launch Email app again, you will find that Email logs out automatically.
Time: 14:36
See attachments: logcat_1436.txt and Aries_KK v2.5.3gp

[2.Testing Steps]: 
1.Afer you've updated Aries build to  20150827165844, launch Email app.
2.Log in a gmail account or a hotmail account by manual setup and wait about 30s.
3.Tap the home button to return to homescreen.
4.Long press power button, and reboot the device.
5.Launch Email app.

[3.Expected Result]: 
5.It keeps loging in.

[4.Actual Result]: 
5.It logs out automatically.

[5.Reproduction build]: 
Device: Aries KK v2.5 (Affected)
Build ID               20150913195924
Gaia Revision          4d9b996be4b1935651057d0651461c1a36d98a18
Gaia Date              2015-09-13 10:47:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9ed17db42e3e46f1c712e4dffd62d54e915e0fac
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150913.192006
Firmware Date          Sun Sep 13 19:20:14 UTC 2015
Bootloader             s1

Device: Flame KK v2.5 (Affected)
Build ID               20150913150208
Gaia Revision          4d9b996be4b1935651057d0651461c1a36d98a18
Gaia Date              2015-09-13 10:47:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9ed17db42e3e46f1c712e4dffd62d54e915e0fac
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150913.184300
Firmware Date          Sun Sep 13 18:43:14 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK v2.2 (Unaffected)
Build ID               20150913032501
Gaia Revision          7a427e0f8aa6c185a9e22358006b97c19435ca4a
Gaia Date              2015-09-09 13:06:12
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0d9c46d01861
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150913.065243
Firmware Date          Sun Sep 13 06:52:55 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free test

[8.Note]:
If you set up an email account by automation, and launch email app after reboot but wait for screen timeout, then lock the DUT, this bug will occur, at a high rate(6 out of 10 attempts).
(Reporter)

Comment 1

2 years ago
Created attachment 8660632 [details]
Aries_KK v2.5.3gp
(Reporter)

Updated

2 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Keywords: regression
This is probably the same as bug 1204113.
The logcat doesn't go back in time very far, but it looks like when we startup the local storage does not know we have an account.  Gonna check the log on bug 1204113 for more detail.

09-14 14:36:11.284 I/GeckoDump( 1572): LOG: startupData: {^M
09-14 14:36:11.284 I/GeckoDump( 1572):   "view": "setup_account_info",^M
09-14 14:36:11.284 I/GeckoDump( 1572):   "entry": "default"^M
09-14 14:36:11.284 I/GeckoDump( 1572): }^M
09-14 14:36:12.104 I/Gecko   ( 1572): WLOG: Mail universe/bridge created and notified!^M
09-14 14:36:12.114 I/GeckoDump( 1572): LOG: cronsync-main: ensureSync called^M
09-14 14:36:12.114 I/GeckoDump(  315): [system] [HomescreenLauncher][20.762] handling keyboardchange^M
09-14 14:36:12.114 I/GeckoDump(  315): [system] [HomescreenWindow][Default Home Screen][homescreen][20.762]  fade out >>>> ^M
09-14 14:36:12.114 I/GeckoDump(  315): [system] [HierarchyManager][20.762] windowopened^M
09-14 14:36:12.114 I/GeckoDump(  315): [system] [InputWindow][Built-in Keyboard][InputWindow_4][20.763] publishing internal event: open^M
09-14 14:36:12.114 I/GeckoDump(  315): [system] [InputWindow][Built-in Keyboard][InputWindow_4][20.763] publishing external event: open^M
09-14 14:36:12.124 I/GeckoDump( 1572): LOG: WRITING LOCAL STORAGE ITEM: data_has_account yes^M
Same bugs per log.  Duping to bug 1204113.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1204113
(Reporter)

Comment 5

2 years ago
Created attachment 8664138 [details]
verified_Aries KK v2.5.3gp

According to the STR of Comment 0, this bug has been verified as pass on latest Flame KK v2.5 and Aries KK v2.5.

Actual result: The email account that was logged in before reboot keeps logging in after reboot.

See attachment: verified_Aries KK v2.5.3gp
Reproduce rate: 0/6


Device: Flame KK v2.5 (Pass)
Build ID               20150921073455
Gaia Revision          2d370fa35c1a0ee2a637e3772c0843586a5f96c9
Gaia Date              2015-09-21 02:41:31
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/039a8490891595736b16a3ccb17f025f4dcf13eb
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150921.112037
Firmware Date          Mon Sep 21 11:20:52 EDT 2015
Base Image         v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.5 (Pass)
Build ID               20150921174442
Gaia Revision          29991414eb94b6baa1ec2e63fdb4f6dfae05fb01
Gaia Date              2015-09-21 09:27:10
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/197af2fb7e29ff8e4b3b6ced723b6172e954e17d
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150921.170449
Firmware Date          Mon Sep 21 17:04:57 UTC 2015
Bootloader             s1
(Reporter)

Updated

2 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
status-b2g-master: affected → verified
You need to log in before you can comment on or make changes to this bug.