[v2.5][Gaia::UI Tests]test_login_bzlite.py:"KeyError: 'bugzilla'"

RESOLVED FIXED

Status

Firefox OS
Gaia::UI Tests
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Verson Xiong (Leave from Mozilla), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8660651 [details]
2015-09-14-12_Non-Smoketest.html

[Description]
test_login_bzlite.py fails

[Steps to Reproduce]
test_login_bzlite.py

[Reproduction Frequency]
Always, 5/5

Traceback (most recent call last):
  File "/var/lib/jenkins/workspace/B2G.master.PVT.FlameKK.gaiatest.non-smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.17-py2.7.egg/marionette/marionette_test.py", line 296, in run
    testMethod()
  File "/var/lib/jenkins/workspace/B2G.master.PVT.FlameKK.gaiatest.non-smoketest/tests/python/gaia-ui-tests/gaiatest/tests/functional/bzlite/test_login_bzlite.py", line 15, in test_login_BugzillaLite
    bugzilla_lite.login(self.testvars['bugzilla']['user'], self.testvars['bugzilla']['password'])
KeyError: 'bugzilla'

[Build info]
Device firmware (base)	L1TC000118D0
Device firmware (date)	13 Sep 2015 18:35:08
Device firmware (incremental)	eng.cltbld.20150913.063455
Device firmware (release)	4.4.2
Device identifier	flame
Gaia date	12 Sep 2015 14:46:27
Gaia revision	2a7461a2c839
Gecko build	20150913030230
Gecko revision	68718290640b0ca195344fa5cc4c55fbc260e19e
Gecko version	43.0a1

[Attachments]
2015-09-14-12_Non-Smoketest

Updated

2 years ago
Component: Gaia::Homescreen → Gaia::UI Tests
In order to make this test work, you need this field in testvars.json[1]. Paul, is there a place I can update this file?

[1] https://github.com/mozilla/webqa-credentials/blob/master/b2g/common.json#L60
Flags: needinfo?(pyang)

Comment 2

2 years ago
looks like a private file I can't access and a webqa repository.
ni? Dave for more information.
Flags: needinfo?(pyang) → needinfo?(dave.hunt)
Yeah, that repository was used because it's private. Web QA don't actually use it any more. Basically you need a JSON file with a "bugzilla" key. The value should be an object with "user" and "password" keys. These should correlate to a Bugzilla account. Note that I am not familiar with the tests that use these account details, so I don't know what instance of Bugzilla it will need to be associated with. Once you have a JSON file with these values you can use the --testvars command line option to specify the path to the file.
Flags: needinfo?(dave.hunt)
I sent the credentials to Paul in private.

Comment 5

2 years ago
Thank you, Johan and Paul.

I have added the credentials to json file.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.