Closed Bug 1204459 Opened 5 years ago Closed 5 years ago

Fennec build error. "No resource found that matches the given name 'android:Widget.Material.Button.Colored'"

Categories

(Firefox Build System :: Android Studio and Gradle Integration, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1195691

People

(Reporter: jerry, Unassigned)

Details

I try to build fennec at my linux desktop with today's gecko(git commit aea523aed14c26dfd737aeeb51411133cc2470c0), and do the config as [1].
But I still get the error as:

7625:15:10.16 /home/bignose/.mozbuild/android-sdk-linux/extras/android/support/v7/appcompat/res/values-v23/styles_base.xml:20: error: Error retrieving parent for item: No resource found that matches the given name 'android:Widget.Material.Button.Colored'.
7627:15:10.16 /home/bignose/.mozbuild/android-sdk-linux/extras/android/support/v7/appcompat/res/values-v23/styles_base_text.xml:19: error: Error retrieving parent for item: No resource found that matches the given name 'android:TextAppearance.Material.Widget.Button.Inverse'.

This is my mozconfig:
# Build Firefox for Android:
ac_add_options --enable-application=mobile/android
ac_add_options --target=arm-linux-androideabi

# With the following Android SDK and NDK:
ac_add_options --with-android-sdk="/path/to/android-sdk/platforms/android-22"
ac_add_options --with-android-ndk="/path/to/android-ndk-r8e"

The ndk version is r8e not r10e as the configure in wiki [1]. It's shown from "./mach bootstrap".
I'm not sure why I go through "android-sdk-linux/extras/android/support/v7/appcompat/res/values-v23" folder. I should use android api 22.

[1]
https://wiki.mozilla.org/Mobile/Fennec/Android#Preparing_a_Fennec_mozconfig
This is a known problem when building with support library 23. You can find help here:
https://mobile.etherpad.mozilla.org/109
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1195691
The long term solution is tracked in bug 1108782.
Product: Firefox for Android → Firefox Build System
You need to log in before you can comment on or make changes to this bug.