[user story] Add-on file format is validated as .zip on submission

VERIFIED FIXED

Status

Tracking
User Story
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: ddurst, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa-needed])

(Reporter)

Description

2 years ago
See: https://www.pivotaltracker.com/story/show/102637512

https://wiki.mozilla.org/WebExtensions#Packaging_2
(Reporter)

Comment 1

2 years ago
Krupa: useful validation test cases in Activity of https://www.pivotaltracker.com/story/show/102637512
Flags: needinfo?(krupa.mozbugs)

Comment 2

2 years ago
checked for happy paths and error messages.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(krupa.mozbugs)
Resolution: --- → FIXED
mass-flag feature-b2g
feature-b2g: --- → 2.5+
(Reporter)

Updated

2 years ago
feature-b2g: 2.5+ → ---
Priority: -- → P1
Whiteboard: [qa-needed]

Comment 4

2 years ago
Verified on MP-dev FF44(Win 7).
Please see the screencast: http://screencast.com/t/TSBgDiawUA3

If the decision is that the non-zip files are also accepted, then the info message below the "select file" button should be changed.

Reopening this or logging another issue?
Flags: needinfo?(ddurst)
(Reporter)

Comment 5

2 years ago
The guidance is a little misleading. It needs to be a zip *format*, but not a .zip file extension necessarily. This is by design. That said, we'd *prefer* folks to use .zip extension, so I'm OK with the implication.

I defer to krupa.
Flags: needinfo?(ddurst) → needinfo?(krupa.mozbugs)

Comment 6

2 years ago
I think we are fine.
Status: RESOLVED → VERIFIED
Flags: needinfo?(krupa.mozbugs)
You need to log in before you can comment on or make changes to this bug.