Closed Bug 1204815 Opened 4 years ago Closed 4 years ago

[Bluetooth]The Bluetooth earphone can not be disconnected.

Categories

(Firefox OS Graveyard :: Bluetooth, defect, major)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(b2g-v2.2 unaffected, b2g-master verified)

VERIFIED DUPLICATE of bug 1202060
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: wangxin, Unassigned)

Details

(Keywords: regression, Whiteboard: [2.5-aries-test-run-2])

Attachments

(2 files)

[1.Description]:
[Aries KKv2.5][Flame v2.5][Bluetooth]When user tries to disconnect a paired Bluetooth earphone by choosing the "Disconnect" item, the earthphone is still connected.
See log:"logcat_1416.txt"
See video:"Aries_v2.5.3GP"
Found Time:14:16

[2.Testing Steps]: 
1. Launch "Settings"->"Bluetooth"
2. Connect a Bluetooth earphone(Sony  MW600).
3. Tap the name of the earphone which is listed in Paired devices .
4. Choose "Disconnect"

[3.Expected Result]: 
4. The Bluetooth earphone should be disconnected.

[4.Actual Result]: 
4. The Bluetooth earphone is still connected.

[5.Reproduction build]: 
Device: Aries KK 2.5 (Affected) 
Build ID               20150915002802
Gaia Revision          f37e8f732e0af961b43e912629c84c9e2ceda55d
Gaia Date              2015-09-14 02:12:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ce211c03a51cadee6b45673394ec3cbfd620830f
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150914.234841
Firmware Date          Mon Sep 14 23:48:49 UTC 2015
Firmware Version       v18D v4
Bootloader             s1

Device: Flame KK 2.5 (Affected) 
Build ID               20150914150204
Gaia Revision          f37e8f732e0af961b43e912629c84c9e2ceda55d
Gaia Date              2015-09-14 02:12:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/fba4b0cd3823975949765acc0b16b964d1712b75
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150914.182849
Firmware Date          Mon Sep 14 18:29:02 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.2 (Unaffected) 
Build ID               20150914032507
Gaia Revision          7a427e0f8aa6c185a9e22358006b97c19435ca4a
Gaia Date              2015-09-09 13:06:12
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0d9c46d01861
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150914.065302
Firmware Date          Mon Sep 14 06:53:13 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
9034
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1202060
Hi SK,

According to comment 3, please recheck the bug, thanks.
Flags: needinfo?(wangxin)
This bug has been verified as pass on latest Flame v2.5 and Aries v2.5.
STR: Same STR as Comment 0

Actual result:
The Bluetooth earphone can be disconnected.

Flame v2.5(pass):
Build ID               20150920150205
Gaia Revision          e67d319d0854e32e23210784eb9c4e1b8a025adb
Gaia Date              2015-09-19 07:42:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ccd6b5f5e544c1d708849144943a776941bd3794
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150920.182952
Firmware Date          Sun Sep 20 18:30:04 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Aries KK v2.5(pass):
Build ID               20150920050928
Gaia Revision          e67d319d0854e32e23210784eb9c4e1b8a025adb
Gaia Date              2015-09-19 07:42:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ccd6b5f5e544c1d708849144943a776941bd3794
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150920.042926
Firmware Date          Sun Sep 20 04:29:33 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
Flags: needinfo?(wangxin)
You need to log in before you can comment on or make changes to this bug.