Share a contact from a device to test device via NFC, the "Filename" screen is displayed as blank screen.

VERIFIED FIXED in Firefox OS master

Status

P2
major
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: yue.xia, Assigned: arcturus)

Tracking

unspecified
FxOS-S8 (02Oct)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-master verified)

Details

(Whiteboard: [NG Gaia Contacts][2.5-aries-test-run-2])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8661140 [details]
logcat_AriesKK2.5_1733.txt

[1.Description]:
[AriesKK v2.5][Flame KK v2.5][NFC]Share a contact from a device to test device via NFC, slide forward to send the contact to test phone, the "Filename" screen is displayed as blank screen.
See attachment: logcat_AriesKK2.5_1733.txt & AriesKK2.5_video.3gp
Found at: 17:33

[2.Testing Steps]: 
1. Go to "Settings", Switch on NFC on test phone and another phone. 
2. Switch on Bluetooth on test phone and another phone. 
3. Go to "Contacts" on another phone and enter an contact's detail screen . 
4. Tap two phones together.
5. Slide forward to send the contact to test phone.


[3.Expected Result]: 
5. After test phone received the contact, the contact should be displayed on the "Filename" screen and user can import the contact successfully.

[4.Actual Result]: 
5. After test phone received the contact, the "Filename" screen is displayed as blank screen.

[5.Reproduction build]: 
Device: Aries KK 2.5 (Affected) 
Build ID               20150915002802
Gaia Revision          f37e8f732e0af961b43e912629c84c9e2ceda55d
Gaia Date              2015-09-14 02:12:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ce211c03a51cadee6b45673394ec3cbfd620830f
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150914.234841
Firmware Date          Mon Sep 14 23:48:49 UTC 2015
Firmware Version       v18D v4
Bootloader             s1

Device: Flame KK 2.5 (Affected) 
Build ID               20150914150204
Gaia Revision          f37e8f732e0af961b43e912629c84c9e2ceda55d
Gaia Date              2015-09-14 02:12:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/fba4b0cd3823975949765acc0b16b964d1712b75
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150914.182849
Firmware Date          Mon Sep 14 18:29:02 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
13823

[8. Note]:
On Flame KK v2.2, after user slide forward to send the contact to test phone, it will import contact automatically, the "Filename" screen will not be shown, so can't try this bug on Flame KK v2.2.
(Reporter)

Comment 1

3 years ago
Created attachment 8661141 [details]
AriesKK2.5_video.3gp
(Reporter)

Updated

3 years ago
status-b2g-master: --- → affected
Summary: [NCF]Share a contact from a device to test device via NFC, the "Filename" screen is displayed as blank screen. → Share a contact from a device to test device via NFC, the "Filename" screen is displayed as blank screen.

Comment 2

3 years ago
[Blocking Requested - why for this release]:
Import behavior different with previous version; moreover, I tried with the following build and found that contact unable to import when click "import all".

Build ID           	20150920150205
Gaia Revision      	e67d319d0854e32e23210784eb9c4e1b8a025adb
Gaia Date          	2015-09-19 07:42:05
Gecko Revision     	https://hg.mozilla.org/mozilla-central/rev/ccd6b5f5e544c1d708849144943a776941bd3794
Gecko Version      	43.0a1
Device Name        	flame
Firmware(Release)  	4.4.2
Firmware(Incremental)  eng.cltbld.20150920.182952
Firmware Date      	Sun Sep 20 18:30:04 EDT 2015
Bootloader         	L1TC000118D0
blocking-b2g: --- → 2.5?
QA Whiteboard: [COM=NFC]
Component: NFC → Gaia::Contacts
Regression, broken functionality.
blocking-b2g: 2.5? → 2.5+
Priority: -- → P2
Assignee: nobody → francisco
Status: NEW → ASSIGNED
The problem here is that with NFC transfer we don't have a filename, we just have a blob transfer.

My proposal here will be replace the file name, by the activity source, in this case, when no file name, we will display the source. 'nfc'

Maria, does that sound reasonable?
Flags: needinfo?(oteo)
It sounds good to me. Fernando can you have a look at it, please?
Thanks a lot!
Flags: needinfo?(oteo) → needinfo?(fernando.campo)
This bug affects to master and NGA so we need to apply a patch for both branches
Whiteboard: [2.5-aries-test-run-2] → [NG Gaia Contacts][2.5-aries-test-run-2]
Target Milestone: --- → FxOS-S8 (02Oct)
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #4)
> The problem here is that with NFC transfer we don't have a filename, we just
> have a blob transfer.
> 
> My proposal here will be replace the file name, by the activity source, in
> this case, when no file name, we will display the source. 'nfc'
> 
> Maria, does that sound reasonable?
I would swear that I already did that on the first patch, but I can't find it right now :S
Flags: needinfo?(fernando.campo)
Created attachment 8668372 [details] [review]
[gaia] arcturus:bug-1204829 > mozilla-b2g:master
Attachment #8668372 - Flags: review?(ferjmoreno)
Attachment #8668372 - Flags: review?(ferjmoreno) → review+
Duplicate of this bug: 1206280

Updated

3 years ago
Duplicate of this bug: 1210516
This issue is Verified Fixed for Aries 2.5 and Flame 2.5
Result: Contact is transferred successfully with correct message "Imported Contact, No duplicate contacts found."

Environmental Variables:
Device: Aries 2.5 Kk
BuildID: 20151002110438
Gaia: 9a682cb7bc8b7fde624a9b2b3c2d64415a08b04b
Gecko: 5f16c6c2b969f70e8da10ee34853246d593af412
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Environmental Variables:
Device: Flame 2.5 Kk Fullflash (512mb)
Build ID: 20151002030232
Gaia: 9a682cb7bc8b7fde624a9b2b3c2d64415a08b04b
Gecko: 5f16c6c2b969f70e8da10ee34853246d593af412
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [COM=NFC] → [QAnalyst-Triage?][COM=NFC]
status-b2g-master: affected → verified
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage?][COM=NFC] → [QAnalyst-Triage+][COM=NFC]
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.