Flash content doesn't repaint correctly when zooming with Ctrl+MouseWheel

NEW
Unassigned

Status

()

Core
Plug-ins
2 years ago
2 years ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8661147 [details]
screenshot - [e10s] Flash content doesn't repaint correctly when zooming with Ctrl+MouseWheel.png

STR:   (Win7_64, Nightly 43, 32bit, ID 20150913030204, new profile, safe mode)
There should be better STR, but it doesn't happen with some SWFs. So I expect somebody to find another SWF exposing this behavior.

0. Enable e10s, restart browser.
1. Open about:addons -> Plugins, set Shockwave Flash to "Always activate"
2. Set  media.fragmented-mp4.enabled -> false,  media.webm.enabled -> false
If that won't help, then open the following page and disable all preferences to force youtube Flash player
>      about:config?filter=/media.(ogg|opus|windows-media-foundation|wave|webm|mediasource|mediasource.mp4|peerconnection.video|eme|fragmented-mp4).enabled/
3. Open   https://www.youtube.com/watch?v=3IT2Cc_5WxE
4. Press Ctrl (don't release Ctrl)
5. Scroll mouse wheel Up and Down

Result:       [see screenshot] Flash content doesn't repaint correctly when zooming with Ctrl+MouseWheel
Expectations: Flash should repaint correctly
(Reporter)

Comment 1

2 years ago
Hm, I see similar thing in non-e10s mode, but not so noticeable. It's clearly visible in e10s.
Summary: [e10s] Flash content doesn't repaint correctly when zooming with Ctrl+MouseWheel → Flash content doesn't repaint correctly when zooming with Ctrl+MouseWheel
(Reporter)

Updated

2 years ago
See Also: → bug 1157708
(Reporter)

Updated

2 years ago
Has STR: --- → yes
You need to log in before you can comment on or make changes to this bug.