Forwarding Mail does not use correct mail profile

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: s.farquhar, Assigned: bugzilla)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.7) Gecko/20011221
BuildID:    200122106

Whilst replying to mail uses the profile of the account that the mail is located
in, forwarding messages does not.

This causes problems when using multiple mail profiles, as wrong return address
& sig are used.

Reproducible: Always
Steps to Reproduce:

1. Create two mail profiles.
2. Send mail to both of them.
3. From secondary account (not default), forward message (Control + L)


Actual Results:  
1. The profile used to forward message is the default profile, and not the
profile for that account.  
2. Thus the wrong "from" address, and signature are used.  I assume other
settings in the profile are wrong too.

Expected Results:  
1. The profile that the message resides in should be used.
2. This is the behaviour when you reply.


SEVERITY:
1. I use the same computer for business & personal email, which have different
accounts and different sigs.  I have to remember to change the accounts whenever
forwarding from the non-default account

Comment 1

17 years ago
Actual windows milestone release 0.9.7:

In addition, if you save a message as draft, and re-open it, the from: address
is chaged to the address of the first profile.

Comment 2

17 years ago
v 20020309
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 3

17 years ago
True, since MSR 0.9.8. OK Scott?
(Reporter)

Comment 4

17 years ago
W00!

Thanks guys - you've made my days more enjoyable.
verified per reporter, thanks for getting back to this!
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.