ImportError: No module named psutil

RESOLVED DUPLICATE of bug 1204628

Status

RESOLVED DUPLICATE of bug 1204628
3 years ago
3 years ago

People

(Reporter: BenWa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Relevant bash history:
<clone>
  501  cd ~/ben/talos-clean/
  502  python INSTALL.py 
  503  talos
  504  . ./bin/activate
  507  talos -h

Gives:
Traceback (most recent call last):
  File "/Users/bgirard/ben/talos-clean/bin/talos", line 9, in <module>
    load_entry_point('talos==0.0', 'console_scripts', 'talos')()
  File "build/bdist.macosx-10.10-x86_64/egg/pkg_resources.py", line 356, in load_entry_point
    
  File "build/bdist.macosx-10.10-x86_64/egg/pkg_resources.py", line 2476, in load_entry_point
    if ':' in extra:
  File "build/bdist.macosx-10.10-x86_64/egg/pkg_resources.py", line 2190, in load
    yield '*'+part
  File "/Users/bgirard/ben/talos-clean/talos/run_tests.py", line 19, in <module>
    from talos.ttest import TTest
  File "/Users/bgirard/ben/talos-clean/talos/ttest.py", line 28, in <module>
    from talos.talos_process import run_browser
  File "/Users/bgirard/ben/talos-clean/talos/talos_process.py", line 7, in <module>
    import psutil
ImportError: No module named psutil
(Reporter)

Comment 1

3 years ago
Running this fixes it:
pip install psutil
thanks BenWa!  :mconley found this yesterday and we have a fix ready to land in bug 1204628
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1204628
You need to log in before you can comment on or make changes to this bug.