Crash stacks should display source line numbers

RESOLVED FIXED

Status

Socorro
Webapp
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: glandium, Assigned: adrian)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
See for example:
https://crash-stats.mozilla.com/report/index/2c4c6f24-0c12-4427-98d5-94a5d2150913

The crash stack looks like:
0 	mozglue.dll 	JemallocInit::CommitHook(void*, unsigned __int64, unsigned __int64, unsigned __int64, unsigned int) 	memory/build/jemalloc_config.cpp
1 	mozglue.dll 	arena_run_split_large_helper 	memory/jemalloc/src/src/arena.c

When read like this (which happens when bugs are reported), it's not very useful, and the only way to know the line numbers is to either click the links from socorro, or read their url, which, in the case of bug reports means first opening the socorro report.
Would it be good to have the line number  just after the file name, in the same column?  (The second column of the stack). Or better to stick it after the url?
(Reporter)

Comment 2

2 years ago
Something like:

0 	mozglue.dll 	JemallocInit::CommitHook(void*, unsigned __int64, unsigned __int64, unsigned __int64, unsigned int) 	memory/build/jemalloc_config.cpp:124
1 	mozglue.dll 	arena_run_split_large_helper 	memory/jemalloc/src/src/arena.c:440

would work for me.

Although, the revision could be helpful in some cases, but it's obviously the same for all sources, so it would only need to appear once... by the way, it doesn't appear at all on the socorro interface. Only in the source links...

Comment 3

2 years ago
The link in the "Source" column has all that already :)

Comment 4

2 years ago
That said, note that the revision is a fuzzy match as we derive that pretty indirectly, from what I remember.
(Reporter)

Comment 5

2 years ago
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #3)
> The link in the "Source" column has all that already :)

Please re-read comment 0. I said so already. It's not convenient at all.
I agree that this would be useful. Pairs of the form "filename:line_number" are very standard, and are used in lots of different debuggers, profilers, etc.
I could have sworn there used to be line numbers, but then they went away. Maybe I'm confused. I agree that it is much nicer to just have it on the source info, rather than trying to stare at the tiny URL when mousing over the link.
(Assignee)

Comment 8

2 years ago
Created attachment 8746524 [details] [review]
Link to Github pull-request: https://github.com/mozilla/socorro/pull/3310
Assignee: nobody → adrian
(In reply to Andrew McCreight [:mccr8] from comment #7)
> I could have sworn there used to be line numbers, but then they went away.
> Maybe I'm confused. I agree that it is much nicer to just have it on the
> source info, rather than trying to stare at the tiny URL when mousing over
> the link.

I *think* you still get them if we don't have the info to generate a link to version control, like for system headers.
Duplicate of this bug: 893353
Duplicate of this bug: 902150

Comment 12

2 years ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/b92bfb5cee51e498f4bd3911432e0be0779e2af7
Fixes bug 1205068 - Added line numbers after files in threads in report/index page. (#3310)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
I don't line numbers in crash reports yet, e.g. https://crash-stats.mozilla.com/report/index/4692e210-2348-488e-92ab-e76452160425.

Will it take time for this to reach production? Or will it only work on new crash reports?
(Assignee)

Comment 14

2 years ago
We will try to do a deployment today, so it should reach prod by the end of the US day. It will work for all crash reports, as this is a simple font-end change, the data was already there.
You need to log in before you can comment on or make changes to this bug.