Aurora (Fx42): Parental controls theme is not applied

VERIFIED FIXED

Status

()

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: sebastian, Assigned: sebastian)

Tracking

42 Branch
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox42 verified, firefox43 unaffected, fennec42+)

Details

Even though we uplifted the parental controls theme in bug 1182514, it is not applied for a restricted profile on Aurora. This only affects the parental controls theme. Other lightweight themes are working.
Summary: Aurora: Parental controls theme is not applied → Aurora (Fx42): Parental controls theme is not applied
This has been noticed while fixing bug 1205274. Something seems to be different in Aurora but so far I haven't found the cause.
tracking-fennec: --- → ?
Assignee: nobody → s.kaspari
Status: NEW → ASSIGNED
Blocks: FFB, kidfox-v1
Finally found the problem. Packaging assets is a new feature in Fx43 (bug 1160563). The theme png never ends up in the assets folder of the APK. I'll test locally with the patches applied and will request uplift (According to nalexander the risk is low).
tracking-fennec: ? → 43+
tracking-fennec: 43+ → 42+

Updated

4 years ago
Blocks: 1199596

Updated

4 years ago
Blocks: 1186027
Patches from bug 1160563 have been uplifted.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 4

4 years ago
Verified as fixed on both latest Nightly(44.0a1) and Aurora (43.0a2) on Sony Xperia Z2 (Android 5.0.2)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.