Bug 1205323 (shadowdom-initial-release)

[meta] Implement Shadow DOM v1 (slots)

RESOLVED FIXED

Status

()

P3
normal
RESOLVED FIXED
4 years ago
a month ago

People

(Reporter: wilsonpage, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 8 bugs, {dev-doc-complete, meta})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Comment hidden (empty)

Updated

4 years ago
Alias: shadowdom

Comment 1

4 years ago
Thanks for starting this :)
Keywords: dev-doc-needed
(Reporter)

Comment 3

3 years ago
Can we get an update from the DOM team on the progress here?
Flags: needinfo?(overholt)
William told me he's progressing on this but recently he's been helping with some more urgent Push bugs.  William, do you have more detail to add?
Flags: needinfo?(overholt) → needinfo?(wchen)

Updated

3 years ago
Blocks: 1233594
FYI, William told me he's getting close to a set of reviewable patches here.
Flags: needinfo?(wchen)
Depends on: 1281983
Depends on: 1308080

Updated

2 years ago
Blocks: 802882

Comment 6

2 years ago
(In reply to Andrew Overholt [:overholt] from comment #5)
> FYI, William told me he's getting close to a set of reviewable patches here.

How close?
Sorry, work has been put on hold here due to other priorities. We're hoping to pick it up again soon.
Depends on: 992245
Depends on: 1026714
Depends on: 1159768
Assignee: wchen → nobody
Status: ASSIGNED → NEW
Keywords: meta
Priority: -- → P3

Comment 8

2 years ago
Hey guys, any estimates? Would it be possible to finish that by the end of the year?

Comment 9

2 years ago
1. I suggest reading https://notapattern.net/2014/10/14/ways-men-in-tech-are-unintentionally-sexist/

2. That seems unlikely, but that will be around the time we might start working on this again.

Comment 10

2 years ago
1. "Guys" is gender-neutral form. Also note that in the above thread, there are no females posting, so I may be addressing just the people above.

2. Any ideas how much could it take? I'm asking as it would help me to plan my project. If there is no estimate, tough luck, I'll live with that.

Comment 11

2 years ago
Please read the article, it's not. And no estimates.
Comment hidden (abuse-reviewed)
Comment hidden (off-topic)
Comment hidden (off-topic)
Comment hidden (abuse-reviewed)
Hi, everyone - 

Mike Hoye here, Mozilla’s engineering community manager.

Mozilla’s position on inclusivity is detailed in our Community Participation Guidelines, and applies to all Mozilla forums and spaces, including Bugzilla. You can read it here:

https://www.mozilla.org/en-US/about/governance/policies/participation/

It specifically addresses the use of gendered language, and asks all participants in the Mozilla project to be deliberate in our choice of language and communication style. The intention is not only that the Mozilla project be welcoming and inclusive today, but that future participants aren’t driven away by a bad first impression from the tone or content of long-closed bugs.

As well, participation in Bugzilla itself should respect the Bugzilla Etiquette and Contributor guidelines, that you can find here:

https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

I encourage all of you to read both of those documents and take them to heart. If, having done so, you have a contribution to make that can move this bug forward please feel free to add it. If you continue to use this forum to vent your displeasure about our community policies, my next action will be to lock this bug and suspend your accounts.

Feel free to email me directly if you'd like to discuss this further, and have a good day.
@Anne

For us developers, it would be important to hear that Mozilla is committed to implement the Web Components V1 standards in the near future. I understand that you cannot tell an exact date. But when you write that you (Mozilla) "might" start working on this again by the end of the year, that's not very promising.

Shadow Dom is an important part of the Web Components technology and the polyfill has too many problems and is too slow.

Comment 18

2 years ago
To be clear, we want to get custom elements and shadow trees done. They're on the roadmap and they're also planned because they'll help us replace internal usage of XUL and XBL down the line. It's just not possible to give an accurate timeline at this point.

Comment 19

2 years ago
@Anne: Can you shed any light on how Mozilla views Shadow DOM in terms of priority? Is it currently high priority (as it is for Edge) or are there other features that take precedence?
(In reply to dan.chilton from comment #19)
> @Anne: Can you shed any light on how Mozilla views Shadow DOM in terms of
> priority? Is it currently high priority (as it is for Edge) or are there
> other features that take precedence?

I'm sure you'll understand, but that's a very difficult question to answer and I don't think we can say anything more useful than "watch for patches here" :)

Comment 21

2 years ago
I do understand, and appreciate the transparency. Thanks!
Comment hidden (off-topic)
Comment hidden (off-topic)
Depends on: 1281715
Depends on: 1281297
Depends on: 1281714
Depends on: 1281745
Depends on: 1397250
Depends on: 1293844
Depends on: 1404842
Depends on: 1404864
Comment hidden (advocacy)
Depends on: 1405934
No longer depends on: 1404842, 1396568, 1396584, 1402941
Depends on: 1405937
No longer depends on: 992245, 1293844, 1405937
Depends on: 1405937
Depends on: 1415006
Depends on: 1422883

Updated

a year ago
Depends on: 1425685

Comment 25

a year ago
What's the status? Are we close to having any release date?
No longer depends on: 1308080
No longer depends on: 1425685

Updated

a year ago
Depends on: 1439153

Updated

11 months ago
Blocks: 811542
Depends on: 1445392
Depends on: 1446834
Duplicate of this bug: 1435632

Updated

11 months ago
Depends on: 1449560
Depends on: 1450027
Depends on: 1100912
Depends on: 1453789

Updated

10 months ago
Blocks: 1308080
Depends on: 1455891
Depends on: 1455893
Depends on: 1455894
Depends on: 1425866
No longer depends on: 1430307
No longer depends on: 1430308
No longer depends on: 1455893
No longer depends on: 1455894

Updated

10 months ago
Depends on: 1459284

Updated

10 months ago
Depends on: 1459584
No longer depends on: 1459584

Updated

10 months ago
Depends on: 1459590
Depends on: 1459688
Depends on: 1001469
No longer depends on: 1001469
Depends on: 1466406
Depends on: 1466581
Depends on: 1469112
Depends on: 1469277
No longer depends on: 1469277
No longer depends on: 1450027
Depends on: 1473637
Depends on: 1475203

Updated

7 months ago
Depends on: 1475351
No longer depends on: 1475351

Comment 27

7 months ago
I'm going to throw a big party with cake when this lands :) - Go Firefox!
Btw, if you know web sites using shadow dom (v1!), I'd be curious to know.
So far web components are very rarely used feature.

Comment 29

7 months ago
Anything built with Polymer 2/3 or lit-element uses Shadow DOM v1 by default if it's available.

I recently rewrote my personal website admin panel https://github.com/myfreeweb/micro-panel from Polymer 2 to lit-element. Using native Shadow DOM with zero polyfills in Firefox Nightly, works great. (Also tried 61 stable with about:config flags, seems to work fine too.)

One somewhat frustrating thing has been that Inspect Element doesn't penetrate Shadom DOM in Firefox, I had to manually click to expand the whole tree. (Chromium doesn't have this problem.)

BTW the newly popular (6000 github stars) element set https://wiredjs.com is also built with lit-element and uses Shadow DOM v1.
(In reply to greg from comment #29)
> One somewhat frustrating thing has been that Inspect Element doesn't
> penetrate Shadom DOM in Firefox, I had to manually click to expand the whole
> tree. (Chromium doesn't have this problem.)

By the way, this is being fixed in https://bugzilla.mozilla.org/show_bug.cgi?id=1449968. And there's a metabug here tracking all devtools work for webcomponents: https://bugzilla.mozilla.org/show_bug.cgi?id=1448847.

Updated

7 months ago
Depends on: 1475869, 1475870
No longer depends on: 1475869
No longer depends on: 1475870

Comment 31

7 months ago
(In reply to Olli Pettay [:smaug] (vacation Jul 15->) from comment #28)
> Btw, if you know web sites using shadow dom (v1!), I'd be curious to know.
> So far web components are very rarely used feature.

www.ea.com

Comment 32

7 months ago
(In reply to Olli Pettay [:smaug] (vacation Jul 15->) from comment #28)
> Btw, if you know web sites using shadow dom (v1!), I'd be curious to know.
> So far web components are very rarely used feature.
Please take a look at this (somewhat outdated but still relevant) list of sites built with web components (the polymer library specifically).

https://github.com/Polymer/polymer/wiki/Who%27s-using-Polymer%3F

But Polymer is not the only game in town. A number of libraries have cropped up which build upon `customElements` and shadow dom as browser primitives, offering expressive and interesting workflows. These include: 

- https://github.com/hybridsjs/hybrids
- https://github.com/ruphin/gluonjs
- https://github.com/Polymer/lit-element
- https://stenciljs.com/

I'm super-pumped for this to land. I've already moved to FF as my daily driver for personal browsing. With web components and `import()` I'll be able to use it as my full-time development browser as well.

Updated

7 months ago
Depends on: 1478959
Depends on: 1476302
Depends on: 1481079
Depends on: 1481514
No longer depends on: 1480618
No longer depends on: 1483798
Depends on: 1484690

Updated

5 months ago
Depends on: 1489858
No longer depends on: 1489858
Depends on: 1490406

Updated

5 months ago
Depends on: 1495586
No longer depends on: 1495586

Updated

3 months ago
Depends on: 1505547

Updated

3 months ago
Depends on: 1507101
No longer depends on: 1505547
No longer depends on: 1507101
I'm marking this fixed, since this was really a tracking bug for shipping.
Bug 1438607 is new things and tracking for regressions and such.
Perhaps bug titles should be changed a bit.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
Alias: shadowdom → shadowdom_initial_release

Updated

3 months ago
Alias: shadowdom_initial_release → shadowdom-initial-release

Updated

3 months ago
See Also: → bug 889230
Summary: Implement Shadow DOM v1 (slots) → [meta] Implement Shadow DOM v1 (slots)

Docs for this are complete.

Keywords: dev-doc-needed → dev-doc-complete
You need to log in before you can comment on or make changes to this bug.