mondadori.com - text in table cells overlaps on images

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
Italian
P2
normal
RESOLVED WORKSFORME
16 years ago
3 years ago

People

(Reporter: mmc, Unassigned)

Tracking

({pp})

Details

(Whiteboard: [havefix][havecontact], URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+) Gecko/20020116
BuildID:    2002011614

The text in the table in the bottom of the page overlaps with the images. In
comparison with IE, it seems that mozilla cannot apply the CSS formatting.

Reproducible: Always
Steps to Reproduce:
1. open page http://www.mondadori.com
2. look at the table in the bottom

Actual Results:  the text inside the cells overlap with the images and doesn't
have the correct font size and colour.

Expected Results:  the text doesn't overlap with images, and has the font size
and colour defined in the CSS.
(Reporter)

Comment 1

16 years ago
Created attachment 65422 [details]
screenshot of the page
That's exactly how NS4 shows the page.  Is this an effect of quirks mode?
Ok.  This is evangelism.  The page has:

// Function to write style sheet dependng on browser
if (is.ns)	{
  if (is.platform=='mac')	{
    document.write('<link rel="stylesheet" href="css/global_nsmac.css">');
  }
  if (is.platform=='win32')	{
    if (is.ns6)	{
      document.write('<link rel="stylesheet" href="css/global_ns6.css">');
    } else {
      document.write('<link rel="stylesheet" href="css/global_ns.css">');
    }
  }
} else {
  document.write('<link rel="stylesheet" href="css/global_ie.css">');
}

So what happens in Netscape on anything that's not windows or mac (eg on Linux)
is that the stylesheet is never loaded, since a <link> tag is never written!

Fixing this bug in the page makes it render correctly...
Assignee: karnaze → nitot
Status: UNCONFIRMED → NEW
Component: HTMLTables → Europe: West
Ever confirmed: true
Keywords: pp
Product: Browser → Tech Evangelism
QA Contact: amar → caillon
Version: other → unspecified
I didn't look deeply in the code, but using
if (is.ns)
{
	if (is.platform=='mac')
	{
		document.write('<link rel="stylesheet" href="css/global_nsmac.css">');
	}
	else
	{
		if (is.ns6)
		{
			document.write('<link rel="stylesheet" href="css/global_ns6.css">');
		}
		else
		{
			document.write('<link rel="stylesheet" href="css/global_ns.css">');
		}
	}
}
else
{
	document.write('<link rel="stylesheet" href="css/global_ie.css">');
}

should fix it. I dont have a mac to try out how does the page renders with the
mac stylesheet on mozilla...
Priority: -- → P2
Whiteboard: [havefix]
http://home.mondadori.com/credits/default.asp lists a bunch of people we can
contact.
Whiteboard: [havefix] → [havefix][havecontact]
can anyone contact them with the fix ?
Summary: text in table cells overlaps on images → mondadori.com - text in table cells overlaps on images
New Component
Component: Europe: West → Italian

Comment 8

15 years ago
italian default owner
Assignee: nitot → italian
QA Contact: z-caillon-obsolete2 → italian

Comment 9

14 years ago
The site is completely changed and the problem of text overlapping doesn't exist
anymore.
This bug is fixed now.
WFM
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.