[e10s] can't properly drag-n-drop tabs on OSX because dndPanel gets underneath the mouse pointer

RESOLVED DUPLICATE of bug 1204944

Status

()

defect
RESOLVED DUPLICATE of bug 1204944
4 years ago
4 years ago

People

(Reporter: Felipe, Assigned: Felipe)

Tracking

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10sm8+)

Details

Attachments

(1 attachment)

Posted patch patchSplinter Review
The panels should be transparent to the mouse, otherwise it's not possible to reorder tabs or drop them in another window, as the panel sits underneath the mouse pointer.

(Don't know if the panel being underneath the pointer is a bug or not, but in any way this fix probably makes sense by itself)
Attachment #8661991 - Flags: review?(jmathies)
Assignee: nobody → felipc
Status: NEW → ASSIGNED

Updated

4 years ago
Attachment #8661991 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/mozilla-central/rev/005290f8c1d5
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43

Updated

4 years ago
Depends on: 1206508
Backed out due to bug 1206508. I'm changing this bug's title to reflect the problem at hand and try other solutions.

There are three main issues with the dnd panel on OSX (retina-only I suppose) that is causing problems:
 1 - the panel appears underneath the mouse pointer, making mousemove operations go to the panel and not the window behind, which in turn makes the drag-n-drop operation not work while the mouse is on it
 2 - the panel is double of the size than it used to be. I should say that they look nice like this, but I'm not sure if this was an intentional or if it's a consequence of the retina display
 3 - the panel move by half the distance that the mouse pointer move, masquerading somewhat problem #1 as the mouse is able to get out of the way of the panel if moved far enough

I'll see which problems I can fix in this bug and which are better left to another one. I'm hoping that fixing #2 is going to fix the positioning (prob #1) but I'm not sure. #3 is most likely to be left separate unless it's a really direct change to fix it together here
Status: RESOLVED → REOPENED
tracking-e10s: --- → m8+
Resolution: FIXED → ---
Summary: e10s drag-n-drop panel should be mousethrough → [e10s] can't properly drag-n-drop tabs on OSX because dndPanel gets underneath the mouse pointer
Target Milestone: Firefox 43 → ---

Comment 5

4 years ago
Issues 1 and 3 are bug 1204944.
Ah ok, thanks Neil. I'll dupe this bug to yours, and I'll file another one for issue 2.

Btw, would you have any guess on why the patch that I landed here would cause the visual glitches in bug 1206508?
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1204944

Comment 7

4 years ago
While not strictly necessary, since the tabdrag panel doesn't appear over the mouse cursor, I would still add the mousethrough and check the patch in this bug in however.
You need to log in before you can comment on or make changes to this bug.