Closed Bug 1205431 Opened 4 years ago Closed 4 years ago

[regression] Cannot profile latest b2g since bug 1171488

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect)

43 Branch
defect
Not set

Tracking

(firefox43 fixed)

RESOLVED FIXED
Firefox 43
Tracking Status
firefox43 --- fixed

People

(Reporter: jsantell, Assigned: jsantell)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

Bug 1171488 introduced attaching system information to recordings for debugging. When starting a recording, an error is throw at:

Exception: "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
resource://gre/modules/devtools/shared/system.js::getSetting::line 294

Recreatable on build 43.0a1 - 20150914150204
The getSetting code is not correct for working in the child process.  We should use a try / catch as a quick fix and file a follow up to make it work for real.
Attached patch 1205431-b2g-getsettings.patch (obsolete) — Splinter Review
https://treeherder.mozilla.org/#/jobs?repo=try&revision=9f56f43af50f

Not sure how to even write a test for this.. or even test it..
Attachment #8662544 - Flags: review?(jryans)
Comment on attachment 8662544 [details] [diff] [review]
1205431-b2g-getsettings.patch

Review of attachment 8662544 [details] [diff] [review]:
-----------------------------------------------------------------

To be nice to other callers of `getSetting`, also add a try / catch inside that method that rejects its promise in case of error.

The failure is currently on the `let settingsService = Cc["@mozilla.org/settingsService;1"].getService(Ci.nsISettingsService);` line, so we get inside the current if.

You'll still need the try you already added, since the promise will be rejected.

Not aware of a good way to test this today, unfortunately.
Attachment #8662544 - Flags: review?(jryans) → review+
https://hg.mozilla.org/mozilla-central/rev/6b14b48d1883
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.