[Video] Player controls will flicker when they appear while the video is playing

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: AdamA, Assigned: kip)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark], URL)

Attachments

(1 attachment)

Created attachment 8662067 [details]
logcat

Description:
In the video app while watching a video if the user taps the screen to bring up the controls they will flicker.

Prerequisite:
Have videos present in the video app

Repro Steps:
1) Update a Aries to 20150916015546
2) Open the video app
3) Start playing a video
4) Tap screen to invoke player controls
5) Observe video controls

Actual:
Video Controls flicker as they appear

Expected:
It is expected that the controls do not flicker

Environmental Variables:
Device: Aries 2.5 [Full Flash]
Build ID: 20150916015546
Gaia: 994ff1537c2d7ca4d1658806c50f3ceba1053f9b
Gecko: 3e8dde8f8c174cce2c0b65c951808f88e35d1875
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Repro frequency: 4/10
See attached: video clip(https://youtu.be/dSyP0fCpomI), logcat
(Reporter)

Comment 1

3 years ago
This issue DOES occur on Flame 2.5.

Environmental Variables:
Device: Flame 2.5 [Full Flash]
BuildID: 20150916030229
Gaia: 994ff1537c2d7ca4d1658806c50f3ceba1053f9b
Gecko: 3e8dde8f8c174cce2c0b65c951808f88e35d1875
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Result:
Video Controls flicker as they appear
------------------------------------
This issue DOES NOT occur on Flame 2.2.

Environmental Variables:
Device: Flame 2.2 [Full Flash]
BuildID: 20150916003026
Gaia: 409a105b5b8aa93a47952b2899e6935b0e4bd194
Gecko: b857fca4824f
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Result:
The controls did not flicker when appearing
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark]
[Blocking Requested - why for this release]:

Visual regression.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Contact: jthomas
Blocking for 2.5 with a P3 priority. 40% chance to reproduce the issue.
blocking-b2g: 2.5? → 2.5+
Priority: -- → P3
Mozilla Inbound Regression Window

Last Working
Environmental Variables:
Device: Flame 2.5
BuildID: 20150901152923
Gaia: c2582f4be03cd12124b96a263c8d14c774f0ffe4
Gecko: 5b59f670cf52f7c4bb5f2fde2c4174d64f7a1f7e
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

First Broken
Environmental Variables:
Device: Flame 2.5
BuildID: 20150901161726
Gaia: c2582f4be03cd12124b96a263c8d14c774f0ffe4
Gecko: 7d3ce51b85e3a9e79582d947bfdf3708c322328b
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Last Working gaia / First Broken gecko - This issue DOES occur with broken Gecko.
Gaia: c2582f4be03cd12124b96a263c8d14c774f0ffe4
Gecko: 7d3ce51b85e3a9e79582d947bfdf3708c322328b

Last Working gecko / First Broken gaia - This issue does NOT occur with broken Gaia
Gecko: 5b59f670cf52f7c4bb5f2fde2c4174d64f7a1f7e
Gaia: c2582f4be03cd12124b96a263c8d14c774f0ffe4

Mozilla Inbound Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5b59f670cf52f7c4bb5f2fde2c4174d64f7a1f7e&tochange=7d3ce51b85e3a9e79582d947bfdf3708c322328b

This issue is most likely caused by Bug 1157984
Blocks: 1157984
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Kip this issue seems to be caused by the changes for bug 1157984.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(kgilbert)
(Assignee)

Comment 6

3 years ago
I'm investigating now, and have taken the bug.
Assignee: nobody → kgilbert
Flags: needinfo?(kgilbert)
(Assignee)

Comment 7

3 years ago
I have found a culling bug in CompositorOGL::DrawQuad in that changelog range that may be the cause of this issue.

The patch added to Bug 1207326 might correct this issue as well.
(Assignee)

Comment 8

3 years ago
Once Bug 1207326 lands, this should be fixed.  Shall we mark as duplicate?
Depends on: 1207326
(Assignee)

Comment 9

3 years ago
(In reply to :kip (Kearwood Gilbert) from comment #8)
> Once Bug 1207326 lands, this should be fixed.  Shall we mark as duplicate?
To clarify, I haven't reproduced this issue, but expect that it is the same as Bug 1207326, Bug 1205738, Bug 1205515, Bug 1205449, and Bug 1204819.

Once Bug 1207326 lands, could someone please verify that it is fixed before closing as duplicate?
Flags: needinfo?(jthomas)
Bug 1207326 is now confirmed fixed. Can someone please test *this* bug and confirm it's now fixed as well?
This isssue is appearing to be verified fixed for Aries and Flame 2.5
Result: Video controls are no longer flickering when brought up while a video is playing.

Environmental Variables:
Device: Aries 2.5 Kk
BuildID: 20151006110922
Gaia: 60cdaa3d3424db3432dc903e7f9c6c8fa099c06d
Gecko: 89732fcdb0baca70e8b7a25a2725117113f0db80
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Device: Flame 2.5 Kk Fullflash (512mb)
Build ID: 20151006030203
Gaia: 60cdaa3d3424db3432dc903e7f9c6c8fa099c06d
Gecko: 3edc8d4a1e198314f5d7ebd2967b85842beef602
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jthomas) → needinfo?(jmercado)
As this issue no longer occurs I'm resolving it as WFM.  Please reopen if it occurs again.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.