Closed Bug 1205459 Opened 6 years ago Closed 5 years ago

CodeMirror editor text is stretched out while scrolling when layers.async-pan-zoom.enabled is true

Categories

(Core :: Panning and Zooming, defect)

Unspecified
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: gl, Unassigned)

References

Details

(Whiteboard: [devtools-platform])

Attachments

(2 files)

STR:
1. Open DevTools debugger on a Google search result page such as https://www.google.ca/search?q=codemirror&ie=utf-8&oe=utf-8&gws_rd=cr&ei=nO35VZ_jMoizogSh64m4BQ
2. Scroll around the source editor
3. See text stretched 

Make sure the CodeMirror source editor has a lot of lines.
Attached file js.txt
You can also paste this text into the demo at http://codemirror.net/mode/javascript/index.html and see the same issue
Attached image scroll-glitch.gif
screencast of the glitching
Whiteboard: [devtools-platform]
OS: Unspecified → Mac OS X
Marking this as blocking the meta bug for APZ on Desktop.
Blocks: apz-desktop
As far as I can tell comment 0 ("text stretched") is a different issue from comment 1 and comment 2 ("glitching", which I'm assuming refers to the fact that the gutter with the line numbers doesn't stay stuck to the frame). The issue in comment 1/comment 2 is an artifact of the editor using scroll events to position the line number gutter elements, rather than something position:fixed or position:sticky which we can handle directly in the compositor. I'm not able to reproduce the issue in comment 0, although it sounds like it may have been fixed by bug 1195400.

Gabriel, are you still able to reproduce comment 0 in the latest nightly build? If so, can you provide a screenshot or video of the issue?
Flags: needinfo?(gabriel.luong)
No response, assuming fixed.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(gabriel.luong)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.