Default property "font.minimum-size.x-western=10" causes much too big font size on particular web page

RESOLVED INVALID

Status

SeaMonkey
General
--
minor
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: Rainer Bielefeld, Unassigned)

Tracking

unspecified
Unspecified
Windows 7

SeaMonkey Tracking Flags

(seamonkey2.38 unaffected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8662185 [details]
Screenshot shows view with Zoom = 30 %

Steps how to reproduce  with  German SeaMonkey 2.38b1  (Windows NT 6.1; WOW64; rv:41.0)  Gecko/20100101 Firefox/41.0 Build 20150904215228  (Classic Theme) on German WIN7 64bit:

1. In browser go to <https://support.apple.com/en-us/HT201222>
   (if you want with newly created profile)
   » Brown background heading line looks normal
   Bug: Gigantic size of characters for following text
2. To URL location input lint type "about:config" → Confirm Warning → 
   search for "font.minimum-size.x-western" → change setting in
   found hit from 10 to 0
   (Unser Ant found this at mozilla.support.seamonkey 
    "Lots of huge stuff on Apple's web pages? Found its cause...")
   » Now page looks normal

Additional info:
a) Page View was still ok  with EN-US SeaMonkey 2.26  (Portable) 
   Gecko/20120604 Firefox/13.0 Build 20140428215944 ( Classic Theme) on 
   German WIN7 64bit SourceStamp=205f9a8e2840
b) Already reproducible with EN-US SeaMonkey 2.33.1 (German Language
   pack)  Gecko/20100101 Build 20150321194901 (Classic Theme) on 
   German WIN7 64bit
c) No Problem on that page with IE11
d) No problem on that page with FF 43.0a1 (2015-09-16) (what has 
   font.minimum-size.x-western = 0 as default)
e) Problem might be caused by page, but may be with  changed default
   "font.minimum-size.x-western" we might avoid such problems
   Are any reasons known why we have "10" as default?
(Reporter)

Comment 1

2 years ago
f) Minor because not many pages seem to be affected
Severity: normal → minor
OS: Unspecified → Windows 7
(Reporter)

Comment 2

2 years ago
g) I did not find a DUP with <https://bugzilla.mozilla.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=DUPs1205534&sharer_id=41036&list_id=12553610>
(Reporter)

Updated

2 years ago
Summary: property font.minimum-size.x-western=10 causes much too big font size on particular web page → Default property "font.minimum-size.x-western=10" causes much too big font size on particular web page

Comment 3

2 years ago
Is this a bug in the browser or Apple web site's fault?

Comment 4

2 years ago
@Rainer:

Here with the SeaMonkey 2.35 64 Bit (Linux) "font.minimum-size.x-western=" is set to "0" at "Standard", the Apple-Website works normal here. But i see, that the Site has a lot of errors in CSS and HTML!
(Reporter)

Comment 5

2 years ago
(In reply to Michael Speier from comment #4)
(In reply to Ant from comment #3)

e): Probably mainly a problem with wrong HTML / CSS on that web page.
    But a browser should be fault-tolerant, and we will have to check whether that  
    goal can be reached better with "font.minimum-size.x-western=10" or
    "font.minimum-size.x-western=0"?
h) And this one might be INVALID or WFM: For report I did an additional test 
   with a Profile I created few days ago with a SM version I can't remember 
   to test an autocomplete-issue, and this profile has default = 10. 
   But a newly created  profile from SM 38 has default 0 and does not 
   cause the problem.
   I will do some further investigation
status-seamonkey2.38: --- → unaffected
Version: SeaMonkey 2.33 Branch → unspecified
(Reporter)

Comment 6

2 years ago
My results in user report might have been nonsense, currently I can't reproduce a default "font.minimum-size.x-western=10" for newly created profiles with 2.33.1, 2.35, 2.38b1 (all: WIN7).

So INVALID for now.

But I can't be sure that there really is no problem at all because of the nearby newly created test profile what hat "font.minimum-size.x-western=10".

s @all:
Please feel free to reopen this Bug if you can reproduce the problem with a newly created user profile, current SeaMonkey version and a current OS and if you can contribute a step by step instruction how to reproduce the problem reliably.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID

Comment 7

2 years ago
According to the W3C test tool, the cited Web page has 17 HTML errors and 108 CSS errors.  No one should expect Gecko to render such a page without problems.
You need to log in before you can comment on or make changes to this bug.