Closed Bug 120554 Opened 18 years ago Closed 18 years ago

crash if I access a page which include infinity loop written in JavaScript

Categories

(Core :: JavaScript Engine, defect, major)

x86
Windows 2000
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 13350

People

(Reporter: furyo, Assigned: rogerl)

References

()

Details

If I access the page in Mozilla , Mozilla is crash and CPU use become 100%.

IE can abord the script , so I don't have no trouble.

Sample code is
<HTML><BODY>
<SCRIPT LANGUAGE="JavaScript">
<!--
for(;;){
document.write("test");
}
-->
</SCRIPT>
</BODY></HTML>
QA Contact: pschwartau → furyo
Does it crash or only hang?
If it only hangs this is bug 13350.
I'm Japanese , so I can not correctly understand the difference between 'crash'
and  'hang' ...

In my report , I need to kill mozilla.exe compulsorily but Windows is running
with no problem.

Maybe , this is 'only hang' as you say.

I apologize that I didn't carefully read other bug reports.
The difference between crash and hang is the following:

Crash:  program stops execution, all of its windows disappear, it is no longer
        present in the tasklist.

Hang: program is executing but cannot be interacted with, program takes up all
      available CPU, program _is_ in the tasklist.

Since you can kill the program, it's hung not crashed.  Thanks for reporting the
bug, and keep doing so!

*** This bug has been marked as a duplicate of 13350 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
To: Mr.Boris Zbarsky 


Thank you very much!!
I understand 'hang' and 'crash' with your help :-)
Verified Duplicate -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.