When I close FF in fullscreen mode and reopen again the fullscreen mode is not properly restored and the bookmarks bar has disappeared

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: eyesee, Unassigned)

Tracking

42 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150826023504

Steps to reproduce:

Open FF, enable fullscreen mode, close FF, open FF again


Actual results:

Fullscreen mode is not properly restored (window seems to be minimized), and the bookmarks bar is not visible


Expected results:

Fullscreen mode should be restored, bookmark bar should be visible
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64

Comment 1

3 years ago
I can't reproduce it on Win 7, FF40 is restarted in FS mode and if I quit FS, the bookmark toolbar is displayed again.

Can you test:
1) in safe mode:
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

2) with a fresh profile:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Does it work?
Flags: needinfo?(eyesee)
(Reporter)

Comment 2

3 years ago
The affected version is not FF40 but FF Developer Edition (FF42?).
"about:support" does contain the following infos:

"application": {
  "name": "Firefox",
  "version": "42.0a2",
  "buildID": "20150917004025",
  "userAgent": "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0",
  "safeMode": false,
  "updateChannel": "aurora",
  "supportURL": "https://support.mozilla.org/1/firefox/42.0a2/WINNT/de/",
  "numTotalWindows": 1,
  "numRemoteWindows": 1,
  "remoteAutoStart": true
},

I hope it is ok to report any issues for the developer edition here.

Anyway, I have tested what you requested with the following results:

1) Safe mode did not help, same behaviour as reported. Additionally I tried with manually disabled plugins and addons (all of them), with same result.

2) With a newly created blank profile (by using "firefox.exe -P" and creating a new one) it worked as expected - closing in fullscreen mode opened correctly in fullscreenmode again.

Thanks a lot!
Flags: needinfo?(eyesee)

Comment 3

3 years ago
eyesee, is still an issue for you? If not, could we close the bug as worksforme?
Flags: needinfo?(eyesee)
(Reporter)

Comment 4

3 years ago
yes, please close the bug. i could not reproduce it with the new profile. thanks!

Comment 5

3 years ago
Reopen it if it's back.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(eyesee)
Resolution: --- → WORKSFORME

Comment 6

3 years ago
I am experiencing a similar issue in FF41.

Steps to reproduce are the same. (Enter fullscreen. Close FF. Reopen. Exit fullscreen).

Unlike the original issue, when I reopen FF, the browser does open in fullscreen (from which the bookmarks toolbar is not visible). When I exit fullscreen, the bookmark toolbar shows up, but it is empty (no buttons).

I am running Kubuntu 15.04.
You need to log in before you can comment on or make changes to this bug.