Solaris Xsun does not like CMEX10/CMSY10 Type1 fonts

RESOLVED FIXED

Status

()

Core
MathML
RESOLVED FIXED
16 years ago
15 years ago

People

(Reporter: Roland Mainz, Assigned: rbs)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
2002-01-14-08-trunk MathML-enabled build on Solaris 2.7 (+Xsun patch 108376-33)
SPARC does not "like" the  CMEX10/CMSY10 Type1 TeX fonts
(ftp://ftp.ams.org/pub/tex/psfonts/cm/cmps-unix.tar.gz) listed on the MathML
page.

If I only add the Wolfram fonts (xset +fp
/home/gisburn/mathml_fonts/wolfram/Type1) MathML works OK (except that I get the
"you're missing important fonts for MathML"-dialog which requests the
CMEX10/CMSY10 fonts.

If I add those fonts (via % xset +fp /home/gisburn/mathml_fonts/tex_cmps/Type)
_HAVOC_ occurs:
1. the http://www.mozilla.org/projects/mathml/start.xml does not load/refresh
it's display
2. Partially renderd MathML glyphs after scolling the page look like as no
MathML fonts are installed

Very weired behaviour.
Looking at the Xserver log file (/var/dt/Xerrors) shows an interresting error
message:
-- snip --
AUDIT: Thu Jan 17 13:01:28 2002: 7751 Xsun: client 45 connected from local host
  Auth name: SUN-DES-1 ID: 61
CMEX10 not found, using Courier.
CMSY10 not found, using Courier.
CMEX10 not found, using Courier.
AUDIT: Thu Jan 17 13:02:10 2002: 7751 Xsun: client 45 disconnected
-- snip --

Removing the TeX font (via % xset -fp
/home/gisburn/mathml_fonts/tex_cmps/Type1), restarting the Zilla and everything
works normal again.

Solaris Xprt (X print server) has the same problems when the CMEX10/CMSY10 fonts
are in it's font path...
(Reporter)

Comment 1

16 years ago
I've packed all fonts and the fonts.dir/fonts.scale stuff into an archive and
put it on my WWW-server for testing, see
http://puck.informatik.med.uni-giessen.de/people/gisburn/work/mozilla/mathml/mathml_fonts.tar.gz
(use "wget" for downloading, mimetype is wrong... ;-( ).
(Reporter)

Comment 2

16 years ago
katakai:
Can you reproduce this problem on your system ?

Comment 3

16 years ago
Do you have an up to date fonts.dir in that directory?
(Reporter)

Comment 4

16 years ago
AFAIK yes.
Download the archive (see comment #1) and take a look at it yourself... :)

Comment 5

16 years ago
The first question is why do you have .pfa files when the AMS ftp site 
has .pfb ones.

Also, have you tried putting the .afm and the .pfa files in one 
directory?
(Reporter)

Comment 6

16 years ago
tenthumbs@cybernex.net write:
> The first question is why do you have .pfa files when the AMS ftp site 
> has .pfb ones.

Well, there is a tool called pfb2pfa which I used to convert the fonts... :-)
But the error occurs with the original *.pfb files of the fonts, too.
(I am using *.pfa versions of the fonts because Xprt (the X print server) can
(currently) only download *.pfa fonts to the printer...)

> Also, have you tried putting the .afm and the .pfa files in one 
> directory?

Nope, it doesn't help (I am not sure... does the Xserver code use the *.afm
files for anything ?!)

Comment 7

16 years ago
> But the error occurs with the original *.pfb files of the fonts, too

OK, I tried both the .pfa and .pfb fonts on Linux and they seem to work.
You might try starting a separate xfs instance with a special config
file just for that directory and then seeing if fslsfonts will work
against it.

> Nope, it doesn't help (I am not sure... does the Xserver code use the
> *.afm files for anything ?!)

Sometimes I read the docs and they seem to imply that X will use .afm
files but sometimes they seem to say no. It doesn't seem to hurt to make
them available. :-)

Comment 8

16 years ago
Sorry about the spam but I forgot to add that the current cm fonts form 
their ftp site have slightly different metrics from the 1997 versions 
that I have. Might be important, might not.
(Reporter)

Comment 9

15 years ago
Finally I figured-out that you have to run /usr/openwin/bin/makepsres in the
fonts dir to create the "PSres.upr" file. Without this file the Solaris Xservers
rant, scream and refuse to use these fonts.

I assume this is an item for the MathML documentation and the release notes...
(Assignee)

Comment 10

15 years ago
-> Marking FIXED. Good that you finally got these fonts to work... How does that 
feel to see those square roots shine?!?

You have been doing very specific things for Solaris (eg, bug 87285 comment 10), 
care to summarize all that you have been through as step-by-step instructions 
that might be published for the benefit of others?

Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

15 years ago
rbs wrote:
> -> Marking FIXED. Good that you finally got these fonts to work... How does 
> that feel to see those square roots shine?!?

Well, it looks very nice... :)

> You have been doing very specific things for Solaris (eg, bug 87285 comment 
> 10),  care to summarize all that you have been through as step-by-step 
> instructions that might be published for the benefit of others?

Could you please file a bug and assign it to me as a reminder ? Thanks!
(Assignee)

Comment 12

15 years ago
-> The follow-up bug is bug 142718.
You need to log in before you can comment on or make changes to this bug.