Closed Bug 1205644 Opened 7 years ago Closed 6 years ago

firefox ignores video track element when injecting it

Categories

(Core :: Audio/Video: Playback, defect, P3)

40 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1242599

People

(Reporter: tomati, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.93 Safari/537.36

Steps to reproduce:

see fiddle: https://jsfiddle.net/5vko6nby/2/


Actual results:

no text tracks where added


Expected results:

text tracks should be added
this happens also with vtt file from same domain, so no cross origin problem.
fiddle gives true in chrome and false in firefox
i my special implementation, the fix was to move the load between adding sources and tracks instead of doing that after:


this.createVideoSourceElements();
this.video_element_raw.load();
this.createVideoTrackElements();
//this.video_element_raw.load();
Component: Untriaged → Audio/Video
Product: Firefox → Core
Component: Audio/Video → Audio/Video: Playback
In my investigation of bug 1214027, I found that textTrack is updated asynchronously. If you add a setTimeout() call after you add the <track> element and before querying the textTrack property, your code will work the way you expect it to.

I don't know if that resolves the bug or not, however.
See Also: 1214027
Mass change P2 -> P3
Priority: P2 → P3
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 871747
How is this a duplicate?  Everything here is in a document, no?
Flags: needinfo?(bechen)
(In reply to Boris Zbarsky [:bz] from comment #6)
> How is this a duplicate?  Everything here is in a document, no?

The "in a document at bug 871747"  means that the TrackElement is bind to the dom tree.
After some fixes, the TrackElement can work normally if it has a MediaElement parent, bind to the dom tree is not mandatory.
Flags: needinfo?(bechen)
Yes, but in this bug's testcases it's always bound to a DOM tree, no?  So how are they related to bug 871747?
Flags: needinfo?(bechen)
(In reply to Boris Zbarsky [:bz] from comment #8)
> Yes, but in this bug's testcases it's always bound to a DOM tree, no?  So
> how are they related to bug 871747?

hmm, I read the testcase again, Bug 1242599 fix the asynchronous issue in comment 3. So this bug should mark as duplicate to 1242599.
Flags: needinfo?(bechen)
Is the actual testcase for this bug fixed?
(In reply to Boris Zbarsky [:bz] from comment #10)
> Is the actual testcase for this bug fixed?

Yes, I ran nightly to verify the testcase yesterday.
Duplicate of bug: 1242599
You need to log in before you can comment on or make changes to this bug.