[Traceback][prod] TypeError: login_failure() takes exactly 1 argument (2 given)

VERIFIED FIXED

Status

Participation Infrastructure
Phonebook
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: nemo, Assigned: nemo)

Tracking

2015-9.1

Details

(Whiteboard: [qa-])

(Assignee)

Description

3 years ago
Internal Server Error: /browserid/login/
Traceback (most recent call last):
  File "/data/www/mozillians.org/mozillians/vendor-local/src/django/django/core/handlers/base.py", line 111, in get_response
    response = wrapped_callback(request, *callback_args, **callback_kwargs)
  File "/data/www/mozillians.org/venv/lib/python2.7/site-packages/newrelic-2.52.0.40/newrelic/hooks/framework_django.py", line 499, in wrapper
    return wrapped(*args, **kwargs)
  File "/data/www/mozillians.org/mozillians/vendor-local/src/django/django/views/generic/base.py", line 69, in view
    return self.dispatch(request, *args, **kwargs)
  File "/data/www/mozillians.org/mozillians/vendor-local/src/django-browserid/django_browserid/views.py", line 103, in dispatch
    return super(Verify, self).dispatch(request, *args, **kwargs)
  File "/data/www/mozillians.org/venv/lib/python2.7/site-packages/newrelic-2.52.0.40/newrelic/hooks/framework_django.py", line 872, in wrapper
    return wrapped(*args, **kwargs)
  File "/data/www/mozillians.org/mozillians/vendor-local/src/django/django/views/generic/base.py", line 87, in dispatch
    return handler(request, *args, **kwargs)
  File "/data/www/mozillians.org/mozillians/mozillians/common/authbackend.py", line 74, in post
    return super(BrowserIDVerify, self).post(*args, **kwargs)
  File "/data/www/mozillians.org/mozillians/vendor-local/src/django-browserid/django_browserid/views.py", line 96, in post
    return self.login_failure()
  File "/data/www/mozillians.org/mozillians/mozillians/common/authbackend.py", line 69, in login_failure
    return super(BrowserIDVerify, self).login_failure(error)
TypeError: login_failure() takes exactly 1 argument (2 given)
(Assignee)

Comment 1

3 years ago
Looks like a regression introduced after the django-browserid v.1.0 upgrade.
(Assignee)

Updated

3 years ago
Assignee: nobody → jgiannelos

Comment 2

3 years ago
Commit pushed to master at https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/d63c25f02fe78425a18c775fc4792a154a14fd96
[Fix bug 1205664] Fix login_failure regression

* Introduced in django-browserid upgrade from v0.10.1 to v1
* Different definition of `def login_failure()`

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Version: other → next
(Assignee)

Updated

3 years ago
Status: RESOLVED → VERIFIED
Whiteboard: [qa-]
(Assignee)

Updated

3 years ago
Version: next → 2015-9.1
You need to log in before you can comment on or make changes to this bug.