Closed Bug 1205819 Opened 7 years ago Closed 7 years ago

Sanity test error "this.mm is null" on Windows Server 2012 (Remote Desktop)

Categories

(Core :: Graphics, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla43
Tracking Status
firefox43 --- fixed

People

(Reporter: vladan, Assigned: dvander)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20150914030205

Steps to reproduce:

I launched a Windows debug build with "mach run" on a Windows Server 2012 machine (via Remote Desktop) and saw the following error on stdout:

JavaScript error: file:///c:/Users/vdjeric/mozilla-central-debug/obj-i686-pc-mingw32/dist/bin/components/SanityTest.js, line 224: TypeError: this.mm is null

This error is in in the endTest method, on the following line:

this.mm.removeMessageListener(msgName, this);
Attached patch fixSplinter Review
If we don't get an onWindowLoaded message by the timeout, we won't have a MessageManager. Simple fix, but it looks like our timeout value probably isn't great.

I took a sample of 1273 users who had a timeout in the sanity test. Of these, 877 had a firstPaint of more than 6 seconds. Looking at overall telemetry for firstPaint, 20 seconds would cover ~90% of users so let's try that and see how it works.
Assignee: nobody → dvander
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8662759 - Flags: review?(mchang)
Would a longer timeout delay Firefox startup?
Attachment #8662759 - Flags: review?(mchang) → review+
(In reply to Vladan Djeric (:vladan) -- please needinfo! from comment #2)
> Would a longer timeout delay Firefox startup?

Nope, it shouldn't.
https://hg.mozilla.org/mozilla-central/rev/a0afac66eb98
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
This change caused a big different in the GRAPHICS_SANITY_TEST data and triggered a Telemetry alert: 

https://groups.google.com/forum/#!topic/mozilla.dev.telemetry-alerts/bU5LzdV1HUU

dvander: is the new histogram distribution what you were hoping for?
Flags: needinfo?(dvander)
That's exactly what I was hoping for (in part). There's much less timeouts now that we've increased the timeout length. However, the amount of failures detected went up too. That's either good or bad depending on how you look at it (bad that we're failing, but good if we're now disabling video where it didn't work).
Flags: needinfo?(dvander)
You need to log in before you can comment on or make changes to this bug.