"ReferenceError: geoip_country_code is not defined" in self-support on startup

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
10 days ago

People

(Reporter: vladan, Assigned: glind)

Tracking

43 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20150914030205

Steps to reproduce:

Launch a debug mozilla-central build with "mach run" on Windows Server 2012 (over Remote Desktop)


Actual results:

ReferenceError: geoip_country_code is not defined, in repair:7:12353
(Reporter)

Comment 1

3 years ago
gps: Is this in FHR code or the new self-support code?
Flags: needinfo?(gps)
(Reporter)

Comment 2

3 years ago
I see these additional exceptions later on (related?):

1442520218946	Services.HealthReport.HealthReporter	WARN	Saved state file does not exist.

1442520221098	Services.Metrics.ProviderManager	WARN	Provider error: TranslationProvider: Error registering provider from category manager: TypeError: type is undefined (resource://gre/modules/HealthReport.jsm:716:9) JS Stack trace: this.ProviderManager.prototype<.registerProviderFromType@HealthReport.jsm:716:9 < this.ProviderManager.prototype<.registerProvidersFromCategoryManager@HealthReport.jsm:643:23 < _initializeProviderManager@HealthReport.jsm:4464:15 < TaskImpl_run@Task.jsm:314:40 < TaskImpl@Task.jsm:275:3 < createAsyncFunction/asyncFunction@Task.jsm:249:14 < AbstractHealthReporter.prototype<.init/<@HealthReport.jsm:4396:15 < TaskImpl_run@Task.jsm:314:40 < TaskImpl_handleResultValue@Task.jsm:393:7 < TaskImpl_run@Task.jsm:322:13 < Handler.prototype.process@Promise-backend.js:934:23 < this.PromiseWalker.walkerLoop@Promise-backend.js:813:7 < Promise*this.PromiseWalker.scheduleWalkerLoop@Promise-backend.js:744:11 < this.PromiseWalker.schedulePromise@Promise-backend.js:776:7 < this.PromiseWalker.completePromise@Promise-backend.js:711:7 < onSuccess@HealthReport.jsm:3232:9 < promise callback*MetricsStorageSqliteBackend.prototype<._popAndPerformQueuedOperation@HealthReport.jsm:3228:1 < MetricsStorageSqliteBackend.prototype<.enqueueOperation@HealthReport.jsm:3179:7 < MetricsStorageSqliteBackend.prototype<.setAutoCheckpoint@HealthReport.jsm:3119:1 < initTask@HealthReport.jsm:3045:13 < TaskImpl_run@Task.jsm:330:41 < Handler.prototype.process@Promise-backend.js:934:23 < this.PromiseWalker.walkerLoop@Promise-backend.js:813:7 < Promise*this.PromiseWalker.scheduleWalkerLoop@Promise-backend.js:744:11 < this.PromiseWalker.schedulePromise@Promise-backend.js:776:7 < this.PromiseWalker.completePromise@Promise-backend.js:711:7 < onSuccess@HealthReport.jsm:3232:9 < promise callback*MetricsStorageSqliteBackend.prototype<._popAndPerformQueuedOperation@HealthReport.jsm:3228:1 < MetricsStorageSqliteBackend.prototype<.enqueueOperation@HealthReport.jsm:3179:7 < MetricsStorageSqliteBackend.prototype<.checkpoint@HealthReport.jsm:3104:1 < initTask@HealthReport.jsm:3042:15 < TaskImpl_run@Task.jsm:330:41 < promise callback*TaskImpl_handleResultValue@Task.jsm:388:7 < TaskImpl_run@Task.jsm:332:11 < promise callback*TaskImpl_handleResultValue@Task.jsm:388:7 < TaskImpl_run@Task.jsm:332:11 < promise callback*TaskImpl_handleResultValue@Task.jsm:388:7 < TaskImpl_run@Task.jsm:332:11 < promise callback*TaskImpl_handleResultValue@Task.jsm:388:7 < TaskImpl_run@Task.jsm:332:11 < promise callback*TaskImpl_handleResultValue@Task.jsm:388:7 < TaskImpl_run@Task.jsm:332:11 < Handler.prototype.process@Promise-backend.js:934:23 < this.PromiseWalker.walkerLoop@Promise-backend.js:813:7 < Promise*this.PromiseWalker.scheduleWalkerLoop@Promise-backend.js:744:11 < this.PromiseWalker.schedulePromise@Promise-backend.js:776:7 < this.PromiseWalker.completePromise@Promise-backend.js:711:7 < onSuccess@HealthReport.jsm:3232:9 < promise callback*MetricsStorageSqliteBackend.prototype<._popAndPerformQueuedOperation@HealthReport.jsm:3228:1 < MetricsStorageSqliteBackend.prototype<.enqueueOperation@HealthReport.jsm:3179:7 < MetricsStorageSqliteBackend.prototype<.setAutoCheckpoint@HealthReport.jsm:3119:1 < initTask@HealthReport.jsm:2939:15 < TaskImpl_run@Task.jsm:330:41 < promise callback*TaskImpl_handleResultValue@Task.jsm:388:7 < TaskImpl_run@Task.jsm:332:11 < promise callback*TaskImpl_handleResultValue@Task.jsm:388:7 < TaskImpl_run@Task.jsm:332:11 < promise callback*TaskImpl_handleResultValue@Task.jsm:388:7 < TaskImpl_run@Task.jsm:332:11 < TaskImpl@Task.jsm:275:3 < createAsyncFunction/asyncFunction@Task.jsm:249:14 < Task_spawn@Task.jsm:164:12 < MetricsStorageSqliteBackend.prototype<._init@HealthReport.jsm:2906:1 < initTask@HealthReport.jsm:2457:13 < TaskImpl_run@Task.jsm:330:41 < promise callback*TaskImpl_handleResultValue@Task.jsm:388:7 < TaskImpl_run@Task.jsm:332:11 < TaskImpl@Task.jsm:275:3 < createAsyncFunction/asyncFunction@Task.jsm:249:14 < Task_spawn@Task.jsm:164:12 < this.MetricsStorageBackend@HealthReport.jsm:2443:1 < AbstractHealthReporter.prototype<.init/<@HealthReport.jsm:4382:29 < TaskImpl_run@Task.jsm:314:40 < Handler.prototype.process@Promise-backend.js:934:23 < this.PromiseWalker.walkerLoop@Promise-backend.js:813:7 < Promise*this.PromiseWalker.scheduleWalkerLoop@Promise-backend.js:744:11 < this.PromiseWalker.schedulePromise@Promise-backend.js:776:7 < this.PromiseWalker.completePromise@Promise-backend.js:711:7
1442520221104	Services.HealthReport.HealthReporter	WARN	Provider error: TranslationProvider: Error registering provider from category manager: TypeError: type is undefined (resource://gre/modules/HealthReport.jsm:716:9) JS Stack trace: this.ProviderManager.prototype<.registerProviderFromType@HealthReport.jsm:716:9 < this.ProviderManager.prototype<.registerProvidersFromCategoryManager@HealthReport.jsm:643:23 < _initializeProviderManager@HealthReport.jsm:4464:15 < TaskImpl_run@Task.jsm:314:40 < TaskImpl@Task.jsm:275:3 < createAsyncFunction/asyncFunction@Task.jsm:249:14 < AbstractHealthReporter.prototype<.init/<@HealthReport.jsm:4396:15 < TaskImpl_run@Task.jsm:314:40 < TaskImpl_handleResultValue@Task.jsm:393:7 < TaskImpl_run@Task.jsm:322:13 < Handler.prototype.process@Promise-backend.js:934:23 < this.PromiseWalker.walkerLoop@Promise-backend.js:813:7 < Promise*this.PromiseWalker.scheduleWalkerLoop@Promise-backend.js:744:11 < this.PromiseWalker.schedulePromise@Promise-backend.js:776:7 < this.PromiseWalker.completePromise@Promise-backend.js:711:7 < onSuccess@HealthReport.jsm:3232:9 < promise callback*MetricsStorageSqliteBackend.prototype<._popAndPerformQueuedOperation@HealthReport.jsm:3228:1 < MetricsStorageSqliteBackend.prototype<.enqueueOperation@HealthReport.jsm:3179:7 < MetricsStorageSqliteBackend.prototype<.setAutoCheckpoint@HealthReport.jsm:3119:1 < initTask@HealthReport.jsm:3045:13 < TaskImpl_run@Task.jsm:330:41 < Handler.prototype.process@Promise-backend.js:934:23 < this.PromiseWalker.walkerLoop@Promise-backend.js:813:7 < Promise*this.PromiseWalker.scheduleWalkerLoop@Promise-backend.js:744:11 < this.PromiseWalker.schedulePromise@Promise-backend.js:776:7 < this.PromiseWalker.completePromise@Promise-backend.js:711:7 < onSuccess@HealthReport.jsm:3232:9 < promise callback*MetricsStorageSqliteBackend.prototype<._popAndPerformQueuedOperation@HealthReport.jsm:3228:1 < MetricsStorageSqliteBackend.prototype<.enqueueOperation@HealthReport.jsm:3179:7 < MetricsStorageSqliteBackend.prototype<.checkpoint@HealthReport.jsm:3104:1 < initTask@HealthReport.jsm:3042:15 < TaskImpl_run@Task.jsm:330:41 < promise callback*TaskImpl_handleResultValue@Task.jsm:388:7 < TaskImpl_run@Task.jsm:332:11 < promise callback*TaskImpl_handleResultValue@Task.jsm:388:7 < TaskImpl_run@Task.jsm:332:11 < promise callback*TaskImpl_handleResultValue@Task.jsm:388:7 < TaskImpl_run@Task.jsm:332:11 < promise callback*TaskImpl_handleResultValue@Task.jsm:388:7 < TaskImpl_run@Task.jsm:332:11 < promise callback*TaskImpl_handleResultValue@Task.jsm:388:7 < TaskImpl_run@Task.jsm:332:11 < Handler.prototype.process@Promise-backend.js:934:23 < this.PromiseWalker.walkerLoop@Promise-backend.js:813:7 < Promise*this.PromiseWalker.scheduleWalkerLoop@Promise-backend.js:744:11 < this.PromiseWalker.schedulePromise@Promise-backend.js:776:7 < this.PromiseWalker.completePromise@Promise-backend.js:711:7 < onSuccess@HealthReport.jsm:3232:9 < promise callback*MetricsStorageSqliteBackend.prototype<._popAndPerformQueuedOperation@HealthReport.jsm:3228:1 < MetricsStorageSqliteBackend.prototype<.enqueueOperation@HealthReport.jsm:3179:7 < MetricsStorageSqliteBackend.prototype<.setAutoCheckpoint@HealthReport.jsm:3119:1 < initTask@HealthReport.jsm:2939:15 < TaskImpl_run@Task.jsm:330:41 < promise callback*TaskImpl_handleResultValue@Task.jsm:388:7 < TaskImpl_run@Task.jsm:332:11 < promise callback*TaskImpl_handleResultValue@Task.jsm:388:7 < TaskImpl_run@Task.jsm:332:11 < promise callback*TaskImpl_handleResultValue@Task.jsm:388:7 < TaskImpl_run@Task.jsm:332:11 < TaskImpl@Task.jsm:275:3 < createAsyncFunction/asyncFunction@Task.jsm:249:14 < Task_spawn@Task.jsm:164:12 < MetricsStorageSqliteBackend.prototype<._init@HealthReport.jsm:2906:1 < initTask@HealthReport.jsm:2457:13 < TaskImpl_run@Task.jsm:330:41 < promise callback*TaskImpl_handleResultValue@Task.jsm:388:7 < TaskImpl_run@Task.jsm:332:11 < TaskImpl@Task.jsm:275:3 < createAsyncFunction/asyncFunction@Task.jsm:249:14 < Task_spawn@Task.jsm:164:12 < this.MetricsStorageBackend@HealthReport.jsm:2443:1 < AbstractHealthReporter.prototype<.init/<@HealthReport.jsm:4382:29 < TaskImpl_run@Task.jsm:314:40 < Handler.prototype.process@Promise-backend.js:934:23 < this.PromiseWalker.walkerLoop@Promise-backend.js:813:7 < Promise*this.PromiseWalker.scheduleWalkerLoop@Promise-backend.js:744:11 < this.PromiseWalker.schedulePromise@Promise-backend.js:776:7 < this.PromiseWalker.completePromise@Promise-backend.js:711:7
(In reply to Vladan Djeric (:vladan) -- please needinfo! from comment #2)
> I see these additional exceptions later on (related?):

That is bug 1205968.

(In reply to Vladan Djeric (:vladan) -- please needinfo! from comment #1)
> gps: Is this in FHR code or the new self-support code?

This would be in the new remote self-repair code. Gregg, are you working on that?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(gps) → needinfo?(glind)
Duplicate of this bug: 1206942

Comment 5

3 years ago
Hi,

Is this issue is fixed ???
No, I can still reproduce it. (Just tried up-to-date debug build with a fresh profile, and got this error spammed to my terminal within 30 seconds.) Do you have reason to expect that it should be fixed?
(@Baskar: I'm noticing this seems to be your first bugzilla comment -- welcome! But: please don't comment on bugs unless you're actually adding value.  Drive-by comments tend to just make bugs harder to read and can get your account suspended in extreme cases -- please read https://bugzilla.mozilla.org/page.cgi?id=etiquette.html for more information.  And, apologies if I'm misunderstanding your comment somehow & you're actually involved with fixing this bug.)
Duplicate of this bug: 1202733
Assignee: nobody → glind
Component: Untriaged → Web: Health Report
Product: Firefox → Firefox Health Report
Hello!  Sorry for the delay on this.

Steps taken:

- fixed at:  https://github.com/mozilla/self-repair-server/commit/30f164b1cbfd1047e4e41d1a65a105baf572ca56
- I have punished myself for being slow by doing 10,000 sit ups.  
- I requested that all my previous bonuses be retroactively revoked.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Flags: needinfo?(glind)

Updated

10 days ago
Product: Firefox Health Report → Firefox Health Report Graveyard
You need to log in before you can comment on or make changes to this bug.