Closed Bug 1205833 Opened 4 years ago Closed 4 years ago

dataSubmissionPolicyNotifiedDate() doesn't handle new profiles well

Categories

(Toolkit :: Telemetry, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla43
Tracking Status
firefox43 --- fixed

People

(Reporter: vladan, Assigned: gfritzsche)

References

Details

(Whiteboard: [unifiedTelemetry])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150915004227

Steps to reproduce:

Launched a debug build of Firefox with "mach run" which created a temporary profile


Actual results:

1442520218420	Toolkit.Telemetry	ERROR	TelemetryReportingPolicy::get dataSubmissionPolicyNotifiedDate - Invalid date stored. Log.jsm:749:0


Expected results:

Note that the default value of datareporting.policy.dataSubmissionPolicyNotifiedTime is 0, by design:

http://hg.mozilla.org/mozilla-central/annotate/de0e763b5210/services/datareporting/datareporting-prefs.js#l7
Blocks: 1191461, 1137355
Assignee: nobody → gfritzsche
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Whiteboard: [unifiedTelemetry]
Attachment #8662776 - Flags: review?(alessio.placitelli) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/d21e7e92f11a
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
You need to log in before you can comment on or make changes to this bug.