Closed Bug 1205863 Opened 4 years ago Closed 4 years ago

[Settings] The bottom of long menus will be cut off/blurry

Categories

(Core :: Graphics, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

()

RESOLVED FIXED
mozilla43
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: AdamA, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(4 files)

Attached file logcat
Description:
With long menus in settings the bottom will be cut off or blurry. This is occurring with the main menu, Developer menu, ringtone menu, Alert menu, and manage tones menu. If the user clicks on the empty space they will still be brought to that menu option.

Repro Steps:
1) Update a Aries to 20150917135859
2) Open Settings
3) Scroll to the bottom of the menu
4) Observe bottom of menu

Actual:
The Bottom portion of the menu will be blurry or not visible

Expected:
It is expected the whole menu is shown

Environmental Variables:
Device: Aries 2.5 [Full Flash]
Build ID: 20150917135859
Gaia: aede8622d780ec71f766a3ecccbff74c04aaba4e
Gecko: de0e763b521062d9a9da0ce029792be026886223
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Repro frequency: 10/10
See attached: screenshot, logcat
This issue DOES NOT occur on Flame 2.5.

Environmental Variables:
Device: Flame 2.5 [Full Flash]
BuildID: 20150917030226
Gaia: db6664f0e07e9966283d30cfc7006151fe7103ff
Gecko: e7d613b3bcfe1e865378bfac37de64560d1234ec
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Result:
the whole menu is shown
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Whiteboard: [2.5-Daily-Testing][Spark]
Attached image Alerts menu blurry
[Blocking Requested - why for this release]:

Options in settings will be missing and this is a regression.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
This issue also occurs on latest tinderbox central Flame. I think the nightly Flame tested above was just not new enough which means this is a very recent (within a day) regression.

Working on getting the window.
QA Contact: pcheng
Summary: [Aries][Settings] The bottom of long menus will be cut off/blurry → [Settings] The bottom of long menus will be cut off/blurry
Regression. Blocks 2.5 with P2 priority
blocking-b2g: 2.5? → 2.5+
Priority: -- → P2
mozilla-inbound regression window:

Last Working
Device: Flame 2.5
BuildID: 20150916170539
Gaia: db6664f0e07e9966283d30cfc7006151fe7103ff
Gecko: c5b25c30befc555a669338a15badd715744923ab
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

First Broken
Device: Flame 2.5
BuildID: 20150916170724
Gaia: db6664f0e07e9966283d30cfc7006151fe7103ff
Gecko: c83c2741197af887a19179a24f1ed1ba6f25a661
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c5b25c30befc555a669338a15badd715744923ab&tochange=c83c2741197af887a19179a24f1ed1ba6f25a661

This issue seems likely to be caused by Bug 1191539.
Blocks: 1191539
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Benoit this issue seems to have been caused by bug 1191539.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(bgirard)
I'm away, can you check if it's cause by the last part? If so back only that one out, otherwise back both out.

I'll investigate the issue when I'm back. Thanks!
Flags: needinfo?(bgirard)
(In reply to (Back on Sept. 28) Benoit Girard (:BenWa) from comment #10)
> I'm away, can you check if it's cause by the last part? If so back only that
> one out, otherwise back both out.

I've backed out the last part.
https://hg.mozilla.org/integration/mozilla-inbound/rev/6e112d30103e
Merge of backout: https://hg.mozilla.org/mozilla-central/rev/6e112d30103e
Status: NEW → RESOLVED
Closed: 4 years ago
Component: Gaia::Settings → Graphics
Product: Firefox OS → Core
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.