Closed Bug 1205895 Opened 4 years ago Closed 4 years ago

[Messaging] Copy and Pasting pasting text, triggers MMS to download automatically.

Categories

(Firefox OS Graveyard :: Gaia::System, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

RESOLVED FIXED
FxOS-S9 (16Oct)
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: vbelonenko, Assigned: TYLin)

References

(Blocks 1 open bug, )

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing], [spark])

Attachments

(2 files)

Description:
When you receive Multimedia message and you copy and paste image, it automatically downloads an image.

Repro Steps:
1) Open Messaging Settings--> Select Auto Retrieve off.
2) Send MMS to your mobile device.
3) Receive a Multimedia message ( testing device)
4) Tap on MMS text and copy and paste into text field.
5) Observe that when you copy and paste Multimedia message, it automatically downloads an image.

Actual:
Automatically downloads Multimedia message when you copy and paste.


Expected:
When user downloads Multimedia message, it should not automatically download MMS.

Environmental Variables:
Device: Aries 2.5 kk Full Flash (319 mb)
Build ID: 20150917133514
Gaia: aede8622d780ec71f766a3ecccbff74c04aaba4e
Gecko: 8d4c37a86b576db4ef150dff715a89ff77e84bf5
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Notes: Messaging Settings: Select Auto Retrieve off

Repro frequency: 5/5
See attached: Logcat and Video
This issue also occurs on Flame 2.5 
Result: Copy and Pasting pasting text, triggers MMS to download automatically.

Environmental Variables:
Device: Flame 2.5 kk
Build ID: 20150916030229
Gaia: 994ff1537c2d7ca4d1658806c50f3ceba1053f9b
Gecko: 3e8dde8f8c174cce2c0b65c951808f88e35d1875
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

This issue does not occurs on Flame 2.2
Result: Copy and Pasting pasting text did not trigger MMS to download.

Environmental Variables:
Device: Flame 2.2 kk
Build ID: 20150811123013
Gaia: 102f1299e9eafe3760e1deb44d556b5c4f36b5af
Gecko: 9295034c0ee3
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: regression
It looks like that when we tap on the 'paste' icon, it triggers also the link below.

Ting-Yu, could you please have a look ?
Flags: needinfo?(tlin)
blocking-b2g: --- → 2.5?
(In reply to [:VladimirBelonenko] from comment #0)
> Created attachment 8662682 [details]
> logcat_20150917_1622.txt
> 
> Description:
> When you receive Multimedia message and you copy and paste image, it
> automatically downloads an image.
> 
> Repro Steps:
> 1) Open Messaging Settings--> Select Auto Retrieve off.
> 2) Send MMS to your mobile device.
> 3) Receive a Multimedia message ( testing device)
> 4) Tap on MMS text and copy and paste into text field.
> 5) Observe that when you copy and paste Multimedia message, it automatically
> downloads an image.
> 
> Actual:
> Automatically downloads Multimedia message when you copy and paste.
> 
> 
> Expected:
> When user downloads Multimedia message, it should not automatically download
> MMS.
> 
> Environmental Variables:
> Device: Aries 2.5 kk Full Flash (319 mb)
> Build ID: 20150917133514
> Gaia: aede8622d780ec71f766a3ecccbff74c04aaba4e
> Gecko: 8d4c37a86b576db4ef150dff715a89ff77e84bf5
> Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
> Version: 43.0a1 (2.5)
> Firmware Version: D5803_23.1.A.1.28_NCB.ftf
> User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
> 
> Notes: Messaging Settings: Select Auto Retrieve off
> 
> Repro frequency: 5/5
> See attached: Logcat and Video

(In reply to [:VladimirBelonenko] from comment #1)
> This issue also occurs on Flame 2.5 
> Result: Copy and Pasting pasting text, triggers MMS to download
> automatically.
> 
> Environmental Variables:
> Device: Flame 2.5 kk
> Build ID: 20150916030229
> Gaia: 994ff1537c2d7ca4d1658806c50f3ceba1053f9b
> Gecko: 3e8dde8f8c174cce2c0b65c951808f88e35d1875
> Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
> Version: 43.0a1 (2.5)
> Firmware Version: v18D
> User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
> 
> This issue does not occurs on Flame 2.2
> Result: Copy and Pasting text did not trigger MMS to download.
> 
> Environmental Variables:
Device: Flame 2.2 kk
Build ID: 20150918002506
Gaia: d52d714afd14c6253ddac8fab63f29b8bcf59f2b
Gecko: 3ee82451dd67
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Blocks 2.5 with P3 priority.
blocking-b2g: 2.5? → 2.5+
Flags: needinfo?(ktucker)
Re comment #2:
This bug is strange. This doesn't happen on browser app where the text selection dialog covers a url link.
Flags: needinfo?(tlin)
we may need add evt.stopPropagation in click/mousedown event to not triggers the link below
By the way, it's totally unrelated to settings though :/
Component: Gaia::Settings → Gaia::System
Summary: [Messaging][Settings] Copy and Pasting pasting text, triggers MMS to download automatically. → [Messaging] Copy and Pasting pasting text, triggers MMS to download automatically.
Component: Gaia::System → Selection
Product: Firefox OS → Core
I cannot reproduce this issue on master. However I found that the click event still propagates after handling the commands (cut, copy, etc.) in app_text_selection_dialog.js. Only preventDefault() is called in [1].

https://github.com/mozilla-b2g/gaia/blob/4d4948cfe29cd16bb45314f15a07fe34e6746619/apps/system/js/app_text_selection_dialog.js#L336
Attachment #8673600 - Flags: review?(etienne)
Ting-yu is working on this.
Assignee: nobody → tlin
Comment on attachment 8673600 [details] [review]
[gaia] aethanyc:bug1205895 > mozilla-b2g:master

r=me with a small unit-test added
(we already have a fake stopPropagation method, we just need to spy on it at assert that it gets called)
Attachment #8673600 - Flags: review?(etienne) → review+
Component: Selection → Gaia::System
Product: Core → Firefox OS
Etienne,

Thank you for the review. Your hint for adding unit-test is very helpful. I've updated my PR with a test added.
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/commit/20f795aaa4c98a87b8fb595a3dbaa91c340d0fc3
Status: NEW → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S9 (16Oct)
You need to log in before you can comment on or make changes to this bug.