2FA breaks auth delegation when logged out of BMO

RESOLVED DUPLICATE of bug 1202886

Status

()

bugzilla.mozilla.org
General
RESOLVED DUPLICATE of bug 1202886
3 years ago
3 years ago

People

(Reporter: mcote, Unassigned)

Tracking

(Blocks: 1 bug)

Production

Details

(Reporter)

Description

3 years ago
STR (with MozReview):

1. Ensure 2FA is enabled and configured on BMO.
2. Log out of BMO and reviewboard.mozilla.org (RMO).
3. Log into RMO (https://reviewboard.mozilla.org/account/login/). You'll be redirected to BMO to log in.
4. Enter username & password in BMO and submit form.
5. Enter 2FA code and submit form.

Expected:

You'll be redirected back to RMO and logged in.

Actual:

You are taken to BMO's index page.  You have to go back to RMO and log in again (step 3 above), at which point you'll be logged into RMO instantly.

I believe this is known, but I didn't see a bug for it anywhere.
Sounds similar to bug 1202886?
yup - and already fixed by the patch on bug 1199087.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1202886
You need to log in before you can comment on or make changes to this bug.