Bug 120601 (renault)

renault.co.uk | renault.fr | renault.de - Does not allow Mozilla

VERIFIED FIXED

Status

P2
major
VERIFIED FIXED
17 years ago
4 years ago

People

(Reporter: mozilla, Assigned: tristan)

Tracking

Details

(Whiteboard: [eurocontest], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120
BuildID:    2001112012

Site redirects to an error message which says:

"Some functionalities are not supported by your current browser version. Please
download an upgraded version with the following links:
Netscape Navigator (site is optimized for Netscaped 4.x)
Microsoft Internet Explorer
AOL 6.0"

However the site *would* work with Mozilla if you use a Session ID in the URL
that was generated with another browser.

This bug report also applies to other sites of the same company (www.renault.fr,
www.renault.de)

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.renault.co.uk
2. See the error message
3.

Actual Results:  -

Expected Results:  -

This bug report also applies to other sites of the same company, a major
european car manufacturer (www.renault.fr, www.renault.de)
Confirming.  they appear to do server side sniffing :(
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All

Comment 2

17 years ago
*** Bug 128032 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

17 years ago
Confirming also with N621.
Setting P2.
Priority: -- → P2

Comment 4

17 years ago
*** Bug 131608 has been marked as a duplicate of this bug. ***
Browser sniffing is client-side, problem is both inline and in a linked script :

linked script :
http://www.renault.fr/client_js_lib/dadelus.js

Inline script:

	if ((!document.layers) && (navigator.appVersion.indexOf("MSIE 6") < 0) &&
(navigator.appVersion.indexOf("MSIE 5") < 0) &&
(navigator.appVersion.indexOf("MSIE 4") < 0)) {
		scriptName = '/RenaultSITe' ; 
  		linkString =
'BV_SessionID=@@@@1933720081.1017753050@@@@&BV_EngineID=fadcdjjhlmdebemgcfkmcjidlo.0'
;  
  		theNextPage = eval("'" + scriptName + "/common/browserError.jsp" + "?" +
linkString +"'");
   		window.location = theNextPage ;
	}

Most of the site can be visited with javascript disabled but some pages are
unreadable because of bad browser sniffing and deprecated [layer]
tags or proprietary Misrosoft DOM (document.all).

BTW, the site also sends bad MIME type for CSS files:
http://www.renault.fr/client_js_lib/style.css
-> [application/x-pointplus] MIME type

I could not find any direct email to the IT department, but the legal notice
shows that the web site was designed by Proxicom (Dimension Data) which have an
online contact form :

http://www.proxicom.com/contactus.asp


pascal
summary changes to help finding that bug...
Summary: renault.co.uk - Does not allow Mozilla → renault.co.uk | renault.fr | renault.de - Does not allow Mozilla

Comment 7

17 years ago
Just had a quick tour of their site in IE and it seems that the blocking is due
to a few LAyer based DHTML tricks.

The top of the page has a layer swopping thing
Several pages have a simple image rollover  thing going on. 

It is a trivial thing to fix. I would be happy to work with Renault or the devs
to fix it. I did report a dupe of this bug...
Tony: I was going to do the job, so tell me if you want to work on it.
(to be honest I would appreciate having less work to do ;)
Whiteboard: [eurocontest]

Comment 9

17 years ago
*** Bug 145501 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 10

17 years ago
Contact info for FR site found under the "Info legale" link on bottom left side
of the home page: 
"RENAULT s.a.s.
13/15, quai Alphonse Le Gallo
92100 Boulogne-Billancourt cedex - France
RCS Nanterre 780 129 987
Directeur de la publication  Nicolas PERRARD 
Responsable du site Vincent COLAS 
Ce site web est édité par : Renault et Didata, Inc. "
 

Comment 11

17 years ago
*** Bug 148507 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
renault.de offers under 'contact' comments about the webpage. so i wrote a
polite letter and hope that they will answer.

Comment 13

17 years ago
response of renault.de (quick-and-dirty translation):

"
many thanks for your annotation to our webpresence

we forwarded your email to the responsible department.
our department is very interested in your opinion to realize the wishes and
needs of our customers.
"
Alias: renault

Comment 14

17 years ago
worksforme

renault overworked their homepage (i clicked deep into renault.de and both
renault.fr & renault.co.uk seems to work).
correct me if i'm wrong, but i would agree to change to fixed & resolved.

greetings, renke

Comment 15

17 years ago
Right, renault.fr works 
This is great news indeed, but the site still has problems on some pages ex :

http://www.renault.fr/RenaultSITe/cars/i_vn_interface_contact.jsp?BV_SessionID=@@@@2002561058.1023988396@@@@&BV_EngineID=ccciadcfgmhkjekcfngcfkmdfkjdfml.0&formType=Twingo


Should we fill in another bug or should we keep using this one ?



Comment 17

17 years ago
i would file another bug as the problem of this bug IS fixed - renault.xx does
allow mozilla.
the mentioned error in comment #16 (the corresponding german site is also buggy)
is imho only a result of this fixed bug - many mozilla-users can use the site now

Comment 18

17 years ago
.co.uk is fine, although they still have lesser functionality in some places.
However the site IS accessible now and whilst it doesn't give me some special
effects, I can get to all areas.

Job done :)
Marking FIXED.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
v
Status: RESOLVED → VERIFIED
move...
Component: Europe: West → German
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.