Closed Bug 1206026 Opened 6 years ago Closed 6 years ago

Firefox Sync reports "Sync has not been able to complete in 14 days" after network interruptions

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1170079

People

(Reporter: mcepl, Unassigned)

Details

Attachments

(2 files)

When I loose a network connection (my wifi is flaky) and reconnect, than Firefox claims on the status line that “Sync has not been able to complete during the last 14 days. Please check your network settings.”.

My understanding of this error message is (and perhaps it is my bad English as a second language kicking in) that this is a sign of disaster. In whole 14 days Sync has not been able to synchronize its database once, so something severe had to happen.

So, I flipped on "services.sync.log.appender.file.logOnSuccess" and I can see a whole list of successful syncs during the last 14 days.

Who lies? The status line message, my bad English, or the logs in about:sync-log?
markh: what's the next step here?
Flags: needinfo?(markh)
Summary: Sync spreads alarming news ... → Firefox Sync reports "Sync has not been able to complete in 14 days" after network interruptions
mcepl: your Sync logs, both success and failure, for the last while would be valuable.  There should be nothing sensitive in them, but if you prefer to not post them publicly, feel free to zip them up and email them to {markh,nalexander}@mozilla.com
Flags: needinfo?(mcepl)
Attached file requested logs
(In reply to Nick Alexander :nalexander from comment #2)
> mcepl: your Sync logs, both success and failure, for the last while would be
> valuable.  There should be nothing sensitive in them, but if you prefer to
> not post them publicly, feel free to zip them up and email them to

Here we are.
Flags: needinfo?(mcepl)
These logs are from Firefox 38, so I suspect this is bug 1170079 - you can verify this by seeing if you have a preference "readinglist.scheduler.lastSync". If you do, you can solve this by upgrading or by removing that pref - obviously upgrading is the best option :)

Please let us know if that seems to be the issue.
Flags: needinfo?(markh) → needinfo?(mcepl)
(In reply to Mark Hammond [:markh] from comment #4)
> These logs are from Firefox 38, so I suspect this is bug 1170079 - you can
> verify this by seeing if you have a preference
> "readinglist.scheduler.lastSync". If you do, you can solve this by upgrading
> or by removing that pref - obviously upgrading is the best option :)

Yes, I have this preference. And no, I am a Red Hat QA, so this is the official RHEL 7.2 Firefox I cannot upgrade. I'll see whether reseting the preference helps.
Flags: needinfo?(mcepl)
BTW, I can see in bug 1170079 comment a629080_75935 that it got wontfixed for 38.*. Is it a right idea to do that for ESR version?
(In reply to Matěj Cepl from comment #5)
> Yes, I have this preference.

Great - I'm confident they are the same then - please reopen if that turns out to be wrong.

(In reply to Matěj Cepl from comment #6)
> BTW, I can see in bug 1170079 comment a629080_75935 that it got wontfixed
> for 38.*. Is it a right idea to do that for ESR version?

That pref can only have been set if the profile was used on the Aurora channel, or was set manually, so I think that's fine (profiles are only likely to be in that state for QA or other advanced users)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1170079
You need to log in before you can comment on or make changes to this bug.