[Flame][Music NGA]The album artworks don't show when you select "Albums" .

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Music
P1
enhancement
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Queena.Wen(Leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-master affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
[1.Description]:
[Flame v2.5][Music NGA]The album artwork of an alphabetical list of artists don't show when you select "Albums" in the music app.
See Attachment:
logcat1714.txt&Flame kk_2.5.png
Found Time:
17:15

[2.Testing Steps]: 
1. Launch the Music App and select "Albums" from the bottom of the screen. 

[3.Expected Result]: 
1.The Album view opens, and you see an alphabetical list of artists with the album artwork on the right hand side of the page. 

[4.Actual Result]: 
1.The album artworks don't show.

[5.Reproduction build]: 
Device:Flame KK v2.5(Affected)
Build ID               20150917150223
Gaia Revision          aede8622d780ec71f766a3ecccbff74c04aaba4e
Gaia Date              2015-09-17 03:40:46
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/3929b8fc6c33bf9cc80299743063f0981f545452
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150917.183330
Firmware Date          Thu Sep 17 18:33:40 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
2371
(Reporter)

Updated

3 years ago
status-b2g-master: --- → affected
(Reporter)

Comment 1

3 years ago
Created attachment 8662888 [details]
logcat1714.txt
(Reporter)

Comment 2

3 years ago
Created attachment 8662890 [details]
Flame kk_v2.5.png
This is a known issue.

Comment 4

3 years ago
Wilson, can you link to the dependent bug here. 

Thanks
Hema
Blocks: 1205048
Severity: normal → enhancement
Flags: needinfo?(wilsonpage)
Priority: -- → P1
The fast-list patch landed today [1], next we need to add an interface to <gaia-fast-list> [2] and then use it to render album artwork in Music app (this bug).


[1] https://github.com/gaia-components/fast-list/commit/df589cca905c0c6a34321d9e0efda6bec1bab421
[2] https://github.com/gaia-components/gaia-fast-list/issues/7
Flags: needinfo?(wilsonpage)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1203824

Updated

3 years ago
Resolution: DUPLICATE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.