Closed Bug 1206100 Opened 4 years ago Closed 2 years ago

Panels anchor at different heights on Windows

Categories

(Firefox :: Theme, defect, P4)

All
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1033395
Tracking Status
firefox40 --- unaffected
firefox41 --- unaffected
firefox42 --- affected
firefox43 --- affected
firefox44 --- affected

People

(Reporter: ge3k0s, Unassigned)

Details

(Keywords: polish, regression, Whiteboard: [qx])

Attachments

(1 file)

The panels on Windows anchor at different heights with their respective toolbar buttons. There are at least three anchor placements on Windows.
1. The main menu and Hello panels arrow is slightly covering the buttons.
2. The "show your bookmarks" panel arrow is a bit lower.
3. Almost all other panels have the arrow just touching the base of their respective buttons.

All the arrow should anchor at the same height.
I can't reproduce this on Windows 8 with Firefox 41. Is this a regression, or win10-specific? Which builds does this happen on?
Flags: needinfo?(ge3k0s)
I don't really think it's Windows 10 specific, but I think the issue appears in Firefox 43.
Flags: needinfo?(ge3k0s)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Firefox 42 seems to be affected as well.
I was able to reproduce on Win10 x64.

The difference in panel height with the hamburger menu vs. the other buttons appears to be longstanding (I just reproduced it on a nightly build from last December during the Fx37 dev cycle). So for the purposes of this bug, I'm ignoring that difference for regression range finding purposes. Not saying it isn't an issue in general, though :)

I was able to reproduce a change in behavior with the downloads and bookmarks dropdowns, however. They used to both be at the same starting point flush with the bottom of the button (similar to how the downloads button is shown in the attached screenshot). Bisection on that regression points to bug 1179295.

The Hello panel actually appears to have regressed at a different point. Bisection on that one points to bug 1029937 as the cause.

I'm not sure if it makes sense to try to fix both issues in this bug or to split them out into different ones. Dao/Neil? :)
Blocks: 1179295, 1029937
Flags: needinfo?(neil)
Flags: needinfo?(dao)
Priority: -- → P4
Duplicate of this bug: 1217119
The dup got pixel values for the offset in it. 
Maybe this helps make this fix easier.

(In reply to Markus Jaritz [:maritz] (UX) from comment #0)
> Created attachment 8677022 [details]
> PanelPositionsOff.gif
> 
> Bookmark-panel  is positioned 2px too low, and 1px too far right,
> Pocket-panel    is positioned 5px too low,
> Downloads-panel is positioned 5px too low, and 1px too far right.
This isn't Windows-specific, since we see the same behaviour on OS X, and probably Linux, though I admit to not having checked there yet.
Whiteboard: [qx]
Blocks: fx-qx
No longer blocks: fx-qx
Flags: needinfo?(neil)
Flags: needinfo?(dao+bmo)
Duplicate of this bug: 1366458
For the toolbar we should anchor the panels off of the bottom of the 16 x 16 icon area. This would create a partial overlap of the panel arrow and the visible button area and address the consistency issues.
(In reply to Roman Müller from comment #11)
> With every single update on Nightly for last few weeks I'm finding [issues].

So file bugs.

> Few days ago you removed possibility to move refresh button around.

It wasn't possible in australis-themed Firefox without an add-on, but we'll be adding that possibility in Photon, actually.

> The fact how it [the bookmarks menu is] anchored is however very amusing.
> 
> http://fii.cz/xbuxtcph

Can't reproduce on either OS X or Windows 10. File a bug with more details if you can reproduce on a clean profile - without the abuse this time.
Roman, I encourage you to read our Etiquette and Contributor Guidelines before continuing your participation in this or any other bug. If you can't find a way to communicate in Bugzilla without insulting or demeaning other contributors, don't. If you insist on doing so, my next step will be to lock your account.

Thank you, and have a good weekend.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1033395
You need to log in before you can comment on or make changes to this bug.