[Status bar] After receiving a notification a blue line will appear at the top of the lock screen.

VERIFIED FIXED

Status

Firefox OS
Gaia::System::Status bar, Utility tray, Notification
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Johnt, Assigned: yzen)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [2.5-Daily-Testing][Spark][Systemsfe], URL)

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
Created attachment 8663199 [details]
logcat_20150918_1706.txt

Description:
If the user has a notification that hasn't been checked yet, unlocking the device will have a thin blue line flash at the top of the screen.

Repro Steps:

Prereq: Have a notification that has not yet been checked.

1) Update a Aries to 20150918122511
2) Lock device.
3) Press power button.

Actual:
Blue notification line appears at the top of the blue screen.

Expected:
It is expected that this line will not appear after pressing the power button.

Environmental Variables:
Device: Aries 2.5
Build ID: 20150918122511
Gaia: 4f22dfecdc046fe5223ee858dd06c11b75884740
Gecko: 37c7812ce0e6d10c7e7182f12e752832835e1d67
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf

Repro frequency: 5/5
See attached: Logcat & Video
Video: https://youtu.be/THw3lzXmc44
(Reporter)

Comment 1

2 years ago
This issue DOES occur on the Flame 2.5
Result: Blue notification line appears at the top of the blue screen.

Environmental Variables:
Device: Flame 2.5 Kk Fullflash (319mb)
BuildID: 20150918043022
Gaia: 4f22dfecdc046fe5223ee858dd06c11b75884740
Gecko: 37c7812ce0e6d10c7e7182f12e752832835e1d67
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

-------------------------------------------

This issue does NOT occur on the Flame 2.2
Result: No blue line appears at the top of lockscreen.

Environmental Variables:
Device: Flame 2.2 Kk Fullflash (319mb)
Build ID: 20150918063047
Gaia: 95950c9d48ad2fc2da7686c2b133b750a99cd3da
Gecko: 38d6133e2416
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(jmercado)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark][Systemsfe]
Not requesting blocking on this issue, but lets get a window here.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
QA Whiteboard: [QAnalyst-Triage+]
QA Contact: pcheng
b2g-inbound regression window:

Last Working
Device: Flame 2.5
BuildID: 20150805114342
Gaia: 65941f31e9b6ce23b157c54e9f8a14566a344d0c
Gecko: d983c31fde3d
Version: 42.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

First Broken
Device: Flame 2.5
BuildID: 20150805120242
Gaia: 34ff1f5a704237820ce2e4a4aa09563b23d0e80a
Gecko: 40b2180f99d5
Version: 42.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Last Working Gaia First Broken Gecko - no repro
Gaia: 65941f31e9b6ce23b157c54e9f8a14566a344d0c
Gecko: 40b2180f99d5

Last Working Gecko First Broken Gaia - repro
Gaia: 34ff1f5a704237820ce2e4a4aa09563b23d0e80a
Gecko: d983c31fde3d

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/65941f31e9b6ce23b157c54e9f8a14566a344d0c...34ff1f5a704237820ce2e4a4aa09563b23d0e80a

This issue appears to be caused by changes made in Bug 1189919.
Blocks: 1189919
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Yura this issue began occurring after the changes for bug 1189919.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(yzenevich)
(Assignee)

Updated

2 years ago
Assignee: nobody → yzenevich
Status: NEW → ASSIGNED
Flags: needinfo?(yzenevich)
Created attachment 8664396 [details] [review]
[gaia] yzen:bug-1206305 > mozilla-b2g:master
(Assignee)

Comment 6

2 years ago
Comment on attachment 8664396 [details] [review]
[gaia] yzen:bug-1206305 > mozilla-b2g:master

Pi, would you be able to see if this PR fixes the issue on your side?
Attachment #8664396 - Flags: review?(timdream)
Attachment #8664396 - Flags: feedback?(pcheng)
Attachment #8664396 - Flags: review?(timdream) → review+
QAwanted for the NI
Keywords: qawanted
Comment on attachment 8664396 [details] [review]
[gaia] yzen:bug-1206305 > mozilla-b2g:master

Yes, this does fix the bug for me. Tested on Aries. Bug reproduced 1 out of 1 attempt before patch. Bug reproduced 0 out of 10 attempts after patch.
Attachment #8664396 - Flags: feedback?(pcheng) → feedback+
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
(Assignee)

Comment 9

2 years ago
https://github.com/mozilla-b2g/gaia/commit/d68622100f9c646f313d4cd34025b74aef070963
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Hi Yura,

    This bug has been verified as "Fail" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.
    Could you help to confirm this again? 

Thank you very much.


---------------------------------------------------------------------------------------------------
Actual results: After receiving a notification, locking screen and then tapping Power button again, a blue line appears for 0~1 seconds at the top of the lock screen.

Please see attachments: verify_fail_Flame_v2.5.3gp and logcat_0636.txt
Reproduce rate: 9/10


Device: Flame KK 2.5 (Fail)
Build ID               20150924150202
Gaia Revision          4bb17b24620818cbda0ba0c0d69e0ce3f914e1b7
Gaia Date              2015-09-23 16:06:39
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/001942e4617b2324bfa6cdfb1155581cbc3f0cc4
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150924.183612
Firmware Date          Thu Sep 24 18:36:29 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Fail)
Build ID               20150925003138
Gaia Revision          4bb17b24620818cbda0ba0c0d69e0ce3f914e1b7
Gaia Date              2015-09-23 16:06:39
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/eee4266046984718e4daa99d94ce820f3fd86d32
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150925.001452
Firmware Date          Fri Sep 25 00:15:01 UTC 2015
Bootloader             s1
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Flags: needinfo?(yzenevich)
Created attachment 8665822 [details]
logcat_0636.txt
Created attachment 8665823 [details]
verify_Fail_Flame_v2.5.3gp
(Assignee)

Comment 13

2 years ago
Just tried the very latest master (with this PR in there) on Aires and it seems to work as expected.

* Triggering notification
* Turn the screen off
* Press power to turn the screen on

Observed: lockscreen shows up, no blue line flicker visible above status bar.
Flags: needinfo?(yzenevich)
The build used at comment 10 doesn't include the fix at comment 9. I'll verify this bug later today.
This issue has been verified fixed on Aries and Flame. Following STR, blue line does not appear over lockscreen. Repro rate: 0 out of 10 attempts.

Device: Aries 2.5
BuildID: 20150925134904
Gaia: 5a0a1bb1a863b07528ebc1a04652ed656d8333b3
Gecko: 543e1b3a25887258a70d1f2dab3cb287d0d500e4
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Device: Flame 2.5
BuildID: 20150925030204
Gaia: f1cb3089ee2a77dd779408ca86dbb5e4ed5af0b3
Gecko: e5effeb8e57ceddf679f7784faab0c2cebb1e1e6
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

------

Shally, please double check whether the fix is included on the build that you're testing before failing verification.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][MGSEI-Triage+] → [QAnalyst-Triage?][MGSEI-Triage+]
status-b2g-master: affected → verified
Flags: needinfo?(lixia)
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage?][MGSEI-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Flags: needinfo?(jmercado)
Hi Pi Wei,

After double check, this bug is fixed now. Thanks.
Flags: needinfo?(lixia)
You need to log in before you can comment on or make changes to this bug.