Use of Ctrl to select multiple noncontiguous items in a <select multiple...> list does not work

RESOLVED DUPLICATE of bug 109318

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 109318
16 years ago
16 years ago

People

(Reporter: Cliff Palmer, Assigned: rods (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Within the browser (verified on NT under 0.9.6 and 0.9.7), the use of the
<select ... multiple ...> construct with numerous VALUE clauses does not work
properly when attempting to use Ctrl-click on non-contiguous VALUEs.  Clicking
on the initial Value selects it, but Ctrl-clicking on anothe value deslects the
first one and selects the new one.  A partial sample follows:

<td valign="top"><select size="4" class="FORMlong" multiple
NAME="Question365_6_FormText"><option
VALUE="AnswerName&amp;=|Associates=X|%%%AnswerValue&amp;=|216=X|%%%GDEAnswerValue&amp;=|2=X|???">Associates</option><option
VALUE="AnswerName&amp;=|BS /
BA=X|%%%AnswerValue&amp;=|217=X|%%%GDEAnswerValue&amp;=|3=X|???">BS /
BA</option><option SELECTED VALUE="AnswerName&amp;=|MS /
MA=X|%%%AnswerValue&amp;=|218=X|%%%GDEAnswerValue&amp;=|4=X|???">MS /
MA</option><option
VALUE="AnswerName&amp;=|MBA=X|%%%AnswerValue&amp;=|219=X|%%%GDEAnswerValue&amp;=|5=X|???">MBA</option><option
VALUE="AnswerName&amp;=|Doctorate /
PhD=X|%%%AnswerValue&amp;=|220=X|%%%GDEAnswerValue&amp;=|7=X|???">Doctorate /
PhD</option></select><br><span class="EXPLANATORYtext"></span></td></tr><tr><td
align="right" valign="top" class="BOLD" width="25%">Current industry
experience</td><td valign="top"><select size="4" class="FORMlong" multiple
NAME="Question356_10_FormText"><option SELECTED
VALUE="AnswerName&amp;=|Aerospace /
Defense=X|%%%AnswerValue&amp;=|246=X|%%%GDEAnswerValue&amp;=|1=X|???">Aerospace
/ Defense</option><option VALUE="AnswerName&amp;=|Banking /
Investment=X|%%%AnswerValue&amp;=|247=X|%%%GDEAnswerValue&amp;=|2=X|???">Banking
/ Investment</option><option
VALUE="AnswerName&amp;=|Biotechnology=X|%%%AnswerValue&amp;=|248=X|%%%GDEAnswerValue&amp;=|3=X|???">Biotechnology</option><option
VALUE="AnswerName&amp;=|Educational=X|%%%AnswerValue&amp;=|249=X|%%%GDEAnswerValue&amp;=|22=X|???">Educational</option><option
SELECTED VALUE="AnswerName&amp;=|Electronic
Equipment=X|%%%AnswerValue&amp;=|250=X|%%%GDEAnswerValue&amp;=|4=X|???">Electronic
Equipment</option><option
VALUE="AnswerName&amp;=|Environmental=X|%%%AnswerValue&amp;=|251=X|%%%GDEAnswerValue&amp;=|5=X|???">Environmental</option><option
VALUE="AnswerName&amp;=|Healthcare=X|%%%AnswerValue&amp;=|252=X|%%%GDEAnswerValue&amp;=|6=X|???">Healthcare</option><option
VALUE="AnswerName&amp;=|Medical
Equipment=X|%%%AnswerValue&amp;=|253=X|%%%GDEAnswerValue&amp;=|7=X|???">Medical
Equipment</option><option
VALUE="AnswerName&amp;=|Semiconductor=X|%%%AnswerValue&amp;=|254=X|%%%GDEAnswerValue&amp;=|4=X|???">Semiconductor</option><option
SELECTED VALUE="AnswerName&amp;=|Technology
(Other)=X|%%%AnswerValue&amp;=|255=X|%%%GDEAnswerValue&amp;=|8=X|???">Technology
(Other)</option><option
VALUE="AnswerName&amp;=|Telecommunications=X|%%%AnswerValue&amp;=|256=X|%%%GDEAnswerValue&amp;=|42=X|???">Telecommunications</option><option
VALUE="AnswerName&amp;=|Web /
Internet=X|%%%AnswerValue&amp;=|257=X|%%%GDEAnswerValue&amp;=|8=X|???">Web /
Internet</option><option VALUE="AnswerName&amp;=|Wireless
Systems=X|%%%AnswerValue&amp;=|258=X|%%%GDEAnswerValue&amp;=|8=X|???">Wireless
Systems</option></select><br><span class="EXPLANATORYtext">Select up to 5
industries in which you have experience.</span></td>

Problem prevents proper completion of forms where multiple selections can and
should be made.
form controls.... this has nothing to do with XML, does it?
Assignee: heikki → rods
Component: XML → HTML Form Controls
QA Contact: petersen → madhur
(Reporter)

Comment 2

16 years ago
I do not know what it has to do with, but I encounterit on any form that permits
multiple values to be selected for any particular "field".

Comment 3

16 years ago
This was recently fixed as bug 109318.  If you are still seeing this in a more
recent build, please reopen.

*** This bug has been marked as a duplicate of 109318 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.