M097 crash launching browser [@ nsAString::BeginWriting]

VERIFIED WORKSFORME

Status

()

Core
Networking: Cache
--
critical
VERIFIED WORKSFORME
16 years ago
3 years ago

People

(Reporter: jay, Assigned: gordon)

Tracking

({crash, topcrash})

Trunk
mozilla0.9.9
x86
Windows 2000
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

16 years ago
This seems to be a Windows 200 specific crash on launching the browser.  Here
are a couple of unique stack traces found in Mozilla 0.9.7 Talkback data:

Count   Offset    Real Signature
[ 6   nsAString::BeginWriting 18ef5e23 - nsAString::BeginWriting ]
[ 2   nsAString::BeginWriting 46adaa3e - nsAString::BeginWriting ]
 
     Crash date range: 2002-01-07 to 2002-01-15
     Min/Max Seconds since last crash: 0 - 2439
     Min/Max Runtime: 21 - 684036
     Keyword List :  
     Count   Platform List 
     8   Windows NT 5.0 build 2195
 
     Count   Build Id List 
     8   2001122109
 
     No of Unique Users         7
 
 Stack trace(Frame) 

	 nsAString::BeginWriting
[..\..\dist/include/string\nsAString.h  line 822] 
	 nsACString::do_AppendFromReadable
[d:\builds\seamonkey\mozilla\string\src\nsAString.cpp  line 882] 
	 nsACString::do_AppendFromElementPtr
[d:\builds\seamonkey\mozilla\string\src\nsAString.cpp  line 888] 
	 nsCacheService::CreateRequest
[d:\builds\seamonkey\mozilla\netwerk\cache\src\nsCacheService.cpp  line 664] 
	 nsCacheService::OpenCacheEntry
[d:\builds\seamonkey\mozilla\netwerk\cache\src\nsCacheService.cpp  line 794] 
	 nsCacheSession::OpenCacheEntry
[d:\builds\seamonkey\mozilla\netwerk\cache\src\nsCacheSession.cpp  line 84] 
	 imgCache::Get
[d:\builds\seamonkey\mozilla\modules\libpr0n\src\imgCache.cpp  line 211] 
	 imgLoader::LoadImage
[d:\builds\seamonkey\mozilla\modules\libpr0n\src\imgLoader.cpp  line 121] 
	 nsXBLResourceLoader::LoadResources
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLResourceLoader.cpp  line 131] 
	 nsXBLPrototypeResources::LoadResources
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLPrototypeResources.cpp  line 80] 
	 nsXBLPrototypeBinding::LoadResources
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLPrototypeBinding.cpp  line 409] 
	 nsXBLService::GetBindingInternal
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLService.cpp  line 971] 
	 nsXBLService::BindingReady
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLService.cpp  line 919] 
	 nsXBLBindingRequest::DocumentLoaded
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLService.cpp  line 143] 
	 nsXBLStreamListener::Load
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLService.cpp  line 426] 
	 nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp  line
1847] 
	 nsDocument::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsDocument.cpp  line 3061] 
	 nsXMLDocument::EndLoad
[d:\builds\seamonkey\mozilla\content\xml\document\src\nsXMLDocument.cpp  line 635] 
	 nsXMLContentSink::DidBuildModel
[d:\builds\seamonkey\mozilla\content\xml\document\src\nsXMLContentSink.cpp  line
365] 
	 CWellFormedDTD::DidBuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\nsWellFormedDTD.cpp  line 338] 
	 nsParser::DidBuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp  line 1388] 
	 nsParser::ResumeParse
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp  line 1905] 
	 nsParser::OnStopRequest
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp  line 2523] 
	 nsXBLStreamListener::OnStopRequest
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLService.cpp  line 308] 
	 nsJARChannel::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\protocol\jar\src\nsJARChannel.cpp  line 614] 
	 nsOnStopRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp  line 213] 
	 PL_HandleEvent
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 591] 
	 PL_ProcessPendingEvents
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 524] 
	 _md_EventReceiverProc
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 1072] 
	 nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp  line 303] 
	 main1
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1280] 
	 main
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1597] 
	 WinMain
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1615] 
	 WinMainCRTStartup()  
	 KERNEL32.DLL + 0x17d08 (0x77e97d08)   
 
     (1616530)	Comments: launching browser  and it died
     (1438746)	Comments: I had started for the first time  hit home to go to Slashdot.org 
then loaded mail/news when it crashed.
 
====================================================================================================
     Count   Offset    Real Signature
[ 4   nsAString::BeginWriting 01b803b9 - nsAString::BeginWriting ]
 
     Crash date range: 2002-01-10 to 2002-01-15
     Min/Max Seconds since last crash: 2 - 114269
     Min/Max Runtime: 60 - 402278
     Keyword List :  
     Count   Platform List 
     4   Windows NT 5.0 build 2195
 
     Count   Build Id List 
     4   2001122109
 
     No of Unique Users         4
 
 Stack trace(Frame) 

	 nsAString::BeginWriting
[..\..\dist/include/string\nsAString.h  line 822] 
	 nsACString::do_AppendFromReadable
[d:\builds\seamonkey\mozilla\string\src\nsAString.cpp  line 882] 
	 nsACString::do_AppendFromElementPtr
[d:\builds\seamonkey\mozilla\string\src\nsAString.cpp  line 888] 
	 nsCacheService::CreateRequest
[d:\builds\seamonkey\mozilla\netwerk\cache\src\nsCacheService.cpp  line 664] 
	 nsCacheService::OpenCacheEntry
[d:\builds\seamonkey\mozilla\netwerk\cache\src\nsCacheService.cpp  line 794] 
	 nsCacheSession::OpenCacheEntry
[d:\builds\seamonkey\mozilla\netwerk\cache\src\nsCacheSession.cpp  line 84] 
	 imgCache::Put
[d:\builds\seamonkey\mozilla\modules\libpr0n\src\imgCache.cpp  line 164] 
	 imgLoader::LoadImage
[d:\builds\seamonkey\mozilla\modules\libpr0n\src\imgLoader.cpp  line 224] 
	 nsXBLResourceLoader::LoadResources
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLResourceLoader.cpp  line 131] 
	 nsXBLPrototypeResources::LoadResources
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLPrototypeResources.cpp  line 80] 
	 nsXBLPrototypeBinding::LoadResources
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLPrototypeBinding.cpp  line 409] 
	 nsXBLService::GetBindingInternal
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLService.cpp  line 971] 
	 nsXBLService::BindingReady
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLService.cpp  line 919] 
	 nsXBLBindingRequest::DocumentLoaded
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLService.cpp  line 143] 
	 nsXBLStreamListener::Load
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLService.cpp  line 426] 
	 nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp  line
1847] 
	 nsDocument::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsDocument.cpp  line 3061] 
	 nsXMLDocument::EndLoad
[d:\builds\seamonkey\mozilla\content\xml\document\src\nsXMLDocument.cpp  line 635] 
	 nsXMLContentSink::DidBuildModel
[d:\builds\seamonkey\mozilla\content\xml\document\src\nsXMLContentSink.cpp  line
365] 
	 CWellFormedDTD::DidBuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\nsWellFormedDTD.cpp  line 338] 
	 nsParser::DidBuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp  line 1388] 
	 nsParser::ResumeParse
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp  line 1905] 
	 nsParser::OnStopRequest
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp  line 2523] 
	 nsXBLStreamListener::OnStopRequest
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLService.cpp  line 308] 
	 nsJARChannel::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\protocol\jar\src\nsJARChannel.cpp  line 614] 
	 nsOnStopRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp  line 213] 
	 PL_HandleEvent
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 591] 
	 PL_ProcessPendingEvents
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 524] 
	 _md_EventReceiverProc
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 1072] 
	 nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp  line 303] 
	 main1
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1280] 
	 main
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1597] 
	 WinMain
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1615] 
	 WinMainCRTStartup()  
	 KERNEL32.DLL + 0x17d08 (0x77e97d08)   
 
     (1516652)	Comments: launching browser
     (1487432)	URL: www.schwab.com
     (1487432)	Comments: Running java applets
(Reporter)

Comment 1

16 years ago
Adding crash, topcrash keywords and qawanted to see if anyone can reproduce this.
Keywords: crash, qawanted, topcrash
(Assignee)

Comment 2

16 years ago
Are we still getting talkback crashes here?

Comment 3

16 years ago
Talkback shows 29 incidents on M097, but none yet on M098 or in the last 10 days 
of the Trunk. Unless M098 turns up some incidents in the next few days this one 
looks like WFM. Here are the comments for posterity (the one moving 10K files 
might make an interesting testcase :-) :

M097 (nsAString::BeginWriting):       29
(2416915) - 2001122109: Windows NT  5.0 build 2195 Starting a new instance. 
(SMP) URL: 
(2480533) - 2001122109: Windows NT  5.0 build 2195 Startup (SMP) URL: 
(2479753) - 2001122109: Windows NT  5.0 build 2195 Startup (SMP) URL: ... fast 
start
(2479110) - 2001122109: Windows NT  5.0 build 2195 Startup (SMP) URL: 
(2505985) - 2001122109: Windows NT  5.0 build 2195 Launching mail/news after 
installing enigmail URL: http://wap.sonyerics
sonmobile.com/LOGIC/common/error.asp?type=browser
(2544019) - 2001122109: Windows NT  5.0 build 2195 Startup of mozilla while 
moving 10.000 files (really) URL: 
(2530018) - 2001122109: Windows NT  5.0 build 2195 I was trying to go into mail 
after rebooting URL: 
(2302353) - 2001122109: Windows NT  5.0 build 2195 typing sth. into addressbar 
URL: [local file]
(2372126) - 2001122109: Windows NT  5.0 build 2195 opening mail  URL: 
penny-arcade.com
 
M098 (nsAString::BeginWriting):        0
Trunk (nsAString::BeginWriting):        0
(Assignee)

Comment 4

16 years ago
Okay, we had a string landing in there and I think its bugs got worked out. 
Marking WORKSFORME, we can reopen if we start getting talkback reports again.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Target Milestone: --- → mozilla0.9.9

Comment 5

16 years ago
verified
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsAString::BeginWriting]
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.