Closed Bug 1206414 Opened 4 years ago Closed 4 years ago

Moving the mouse cursor downwards removes suggested pages below address bar

Categories

(Firefox :: Address Bar, defect, critical)

42 Branch
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1192505

People

(Reporter: 2slow4flo, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150919004025

Steps to reproduce:

While typing in the first few letters of a page I like to visit I am moving the mouse cursor downwards from the address bar to the position where the page I want to visit will be.


Actual results:

The suggestions for pages starting with those letters disappear. I also can't bring it back up somehow.


Expected results:

The suggested pages below the address bar should not disappear just because I am moving my mouse cursor.
Severity: normal → critical
Summary: Moving the mouse cursor down removes suggested pages below address bar → Moving the mouse cursor downwards removes suggested pages below address bar
If you want I can make a video (webm) showcasing the bug. This has happened for me for the last 1-2 weeks, so it must be a pretty recent update of the firefox dev edition.
Can you please attach a screencast like you said ? that would be really helpfull.
Thanks
Here it is uploaded on vid.me https://vid.me/TOHX

If you prefer another hoster let me know. I recorded it in .webm format.

I made a new profile typed in a few links and as you can see I can pretty much reliably make the suggestions disappear. I am always typing in the first 3 letters of the page and moving the mouse cursor downwards. Very annoying to lose the page suggestions like that.

Thanks,
Flo
Attached video firefox_cursor_bug.webm
I am just confused, will it's component be location bar or Event handling under core product ?
still, moving to one of them
Component: Untriaged → Location Bar
Could you tell me if my issue is reproducable for you? Only inputs are the first 3 letters of a page and moving the cursor downwards (in the general area where the suggestions will appear).

Thanks in advance!
No, I could not reproduce it though. My one works fine.
may be its happening because of your hidpi display or windows 10
are you using windows 10?
I don't use a hidpi display, but I am using windows 10.
what is the dimension of your display then?
Blocks: windows-10
Can you try using mozregression ( http://mozilla.github.io/mozregression/ ) to find out when this broke?
Flags: needinfo?(2slow4flo)
Ok took me ages to find the version where this was introduced, I was way too optimistic with the last known good date.

Last good build --->
app_name: firefox
build_date: 2015-07-30
build_type: nightly
build_url: https://archive.mozilla.org/pub/mozilla.org/firefox/nightly/2015/07/2015-07-30-03-02-08-mozilla-central/firefox-42.0a1.en-US.win64.zip
changeset: 62469b20ec84
pushlog_url: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=62469b20ec84&tochange=32712cd01159
repo_name: mozilla-central
repo_url: https://hg.mozilla.org/mozilla-central

First bugged build --->
app_name: firefox
build_date: 2015-07-31
US.win64.zip
build_type: nightly
build_url: https://archive.mozilla.org/pub/mozilla.org/firefox/nightly/2015/07/2015-07-31-03-02-06-mozilla-central/firefox-42.0a1.en-US.win64.zip
changeset: ca53d4297f02
pushlog_url: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=62469b20ec84&tochange=ca53d4297f02
repo_name: mozilla-central
repo_url: https://hg.mozilla.org/mozilla-central

Let me know if you need anything else.
Flags: needinfo?(2slow4flo) → needinfo?(gijskruitbosch+bugs)
this happens because when you move the cursor and change selection we cancel the pending query, this happens to avoid replacing what's under the mouse cursor with something different and by that surprising the user.
Though, we end up canceling too often.
This is a dupe btw. Since it seems affecting more users, I'll rise the priority of that bug a little bit.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: --- → DUPLICATE
Duplicate of bug: 1192505
You need to log in before you can comment on or make changes to this bug.