Inconsistent terminology: "SIM" vs "SIM card" and "No SIM inserted" vs "No SIM card"

RESOLVED FIXED in 2.6 S5 - 1/15

Status

Firefox OS
Gaia::System::Status bar, Utility tray, Notification
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: cpeterson, Assigned: vinay)

Tracking

({foxfood})

unspecified
2.6 S5 - 1/15
ARM
Gonk (Firefox OS)
foxfood

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

(Whiteboard: [good first bug][mentor-lang=zh][lang=js])

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

2 years ago
When hot swapping my SIM card in my Sony Z3C, I noticed some inconsistent wording:

1. The notification drawer uses the term "SIM" but the Settings app's "Messaging Settings" uses the term "SIM card".

2. The notification drawer says "No SIM inserted" but the Settings app's "Messaging Settings" just says "No SIM card".

3. The notification drawer also says "No SIM inserted. Insert a SIM to enable Usage." This wording is confusing. What does "enable Usage" mean? Why is "Usage" capitalized? Is it an app?
QA Whiteboard: [foxfood-triage]
Component: Gaia::Feedback → Gaia::System::Status bar, Utility tray, Notification

Comment 1

2 years ago
@tina could you help coordinate with related UX to come out some consistent wordings?
Flags: needinfo?(thsieh)
1. Please replace all the "SIM" by "SIM card" so that the strings for SIM card can be consistent.

2. Please replace "No SIM inserted" by "No SIM card".

3. Sure, the "Usage" is an app which needs SIM card to activate functions.
Flags: needinfo?(thsieh)

Comment 3

2 years ago
Thanks Tina!

Put in backlog and set as good first bug
tracking-b2g: --- → backlog
Whiteboard: [good first bug][mentor-lang=zh][lang=js]
(Assignee)

Comment 4

2 years ago
I am new here. Can I take up this to get to know about Gaia?

Comment 5

2 years ago
Sure, but to test this you need a Firefox OS device to test if the SIM string is correct. 

I'd like to make sure you do have one to make the debugging process more simple. (Or it will be easier to pick other issue as the first bug)
(Assignee)

Comment 6

2 years ago
Created attachment 8703061 [details] [diff] [review]
Changed properties for en-US

I don't really have a device to test this. I have found that all SIM card related strings for Usage have been defined in two files. 
Both these files are for en-US. Corresponding changes may be required in zh-CN as well.

I am not really sure why there are two files. First file defines all the properties. Is the second file only for translation?

It will be great if someone tests this on a Firefox OS device. Thank you.

Comment 7

2 years ago
Thanks for the patch! I've set you as assignee. Since this is a relatively simple task I think its might be fine, but its still better if you can test it on device.



I saw 2 issues that around the patch:

1. The procedure: For gaia patch, we usually 

1. fork from gaia
2. create a github pull request(PR) from your branch
3. attach the PR link as the bugzilla attachment
4 [review]. set review to suggested reviewer

2. l10n requirement:
Developer only need to maintain the english translation.

But for any string change, we need change the id as well (for example, we need rename `widget-authed-sim-heading` because the content is changed) in both .property file and in html/js. The id change will be detected by l10n team and they will help translate to multi-languages.
Assignee: nobody → vinayy765
(Assignee)

Comment 8

2 years ago
Thank you for the procedure. I will create a PR and attach it.

I did not understand l10n part. Do you mean we need to rename all the ids for which string is changed? These ids could have been used at multiple places and it will have to be renamed at all these places. Please clarify. Isn't there any other way to  indicate this change to l10n team?
Flags: needinfo?(gasolin)

Comment 9

2 years ago
yes, we need to rename all the ids for which string is changed
Flags: needinfo?(gasolin)
(Assignee)

Comment 10

2 years ago
Created attachment 8703276 [details] [review]
Changed SIM card strings

Changed the SIM card related strings. Also changed the corresponding id's of the changed strings accordingly.
Attachment #8703061 - Attachment is obsolete: true
Attachment #8703276 - Flags: review?(kevin+bugzilla)
Comment on attachment 8703276 [details] [review]
Changed SIM card strings

This looks generally fine to me, but I think we need to forward the review to Salva, the owner of usage. Thank you for the patch!
Attachment #8703276 - Flags: review?(salva)
Attachment #8703276 - Flags: review?(kevin+bugzilla)
Attachment #8703276 - Flags: feedback+
Comment on attachment 8703276 [details] [review]
Changed SIM card strings

Sorry for the delay. Nice work with this.
Attachment #8703276 - Flags: review?(salva) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/ee02a3b54fde3cebe0c026357865269d2fe1fcb9
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.6 S5 - 1/15
This bug has caused this one to appear: Bug 1238482

So this has to be backed out. Ni Francisco
Status: RESOLVED → REOPENED
Flags: needinfo?(francisco)
Resolution: FIXED → ---
Created attachment 8706878 [details] [review]
[gaia] vinay-y:bug1206474reop > mozilla-b2g:master
(Assignee)

Comment 16

2 years ago
Comment on attachment 8706878 [details] [review]
[gaia] vinay-y:bug1206474reop > mozilla-b2g:master

I have found the errors causing Bug 1238482. These have been corrected and a PR has been added.
Attachment #8706878 - Flags: review?(kevin+bugzilla)
Comment on attachment 8706878 [details] [review]
[gaia] vinay-y:bug1206474reop > mozilla-b2g:master

Sorry, I am not a peer of this module so I will forward the patch over to Salva.

Thank you for the contribution!
Attachment #8706878 - Flags: review?(kevin+bugzilla) → review?(salva)
Comment on attachment 8706878 [details] [review]
[gaia] vinay-y:bug1206474reop > mozilla-b2g:master

This should have been catched by the CI environment (I don't know what happened cause it seems to be green) preventing the branch to be merged. It is better to back out the commit and make a new PR.
Flags: needinfo?(francisco)
Attachment #8706878 - Flags: review?(salva) → review-
Back out: c5fd705948adeba7d333faa4a069e377fd2a46a5

Dear contributor, please provide the new patch in a new PR and mark the former attachments as obsolete and more important give yourself an alias / nick in your profile so I can refer to you with a proper name ;)
Flags: needinfo?(vinayy765)
Well, after digging into what happened here, it seems our l10n mock does not check if the key exists as the localization file is not provided during testing. This lead to the kind of problem we've seen here. My suggestion is to open a follow up to update the tests to use the shared mock for l10n and a second one to provide means to specify the localization file in order to enable the mock to check the existence of the key string and catch this kind of regressions.

If you want to take these tasks, vynay-y, I can guide you.
Created attachment 8707917 [details] [review]
[gaia] vinay-y:bug1206474 > mozilla-b2g:master
(Assignee)

Updated

2 years ago
Attachment #8706878 - Attachment is obsolete: true
Flags: needinfo?(vinayy765)
(Assignee)

Updated

2 years ago
Attachment #8703276 - Attachment is obsolete: true
(Assignee)

Comment 22

2 years ago
Comment on attachment 8707917 [details] [review]
[gaia] vinay-y:bug1206474 > mozilla-b2g:master

I have added a new PR and marked older ones obsolete.

I am willing to take up the task for l10n follow up. But I will need guidance for that.

Thanks.
Attachment #8707917 - Flags: review?(salva)
Comment on attachment 8707917 [details] [review]
[gaia] vinay-y:bug1206474 > mozilla-b2g:master

Looks great to me.
Attachment #8707917 - Flags: review?(salva) → review+
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/commit/df0aecb629da56c44c465e2d8348a7c285f1a3ac
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.