The default bug view has changed. See this FAQ.

Port relevant changes from | bug 885982 - Move MozTCPSocket and MozTCPServerSocket to WebIDL | to Thunderbird

RESOLVED FIXED in Thunderbird 44.0

Status

Thunderbird
Build Config
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: ewong, Assigned: ewong)

Tracking

Trunk
Thunderbird 44.0

Thunderbird Tracking Flags

(thunderbird43 fixed, thunderbird44 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
+++ This bug was initially created as a clone of Bug #1206592 +++

Currently we're busted because of bug 885982.  Need to port the
relevant changes.
(Assignee)

Comment 1

2 years ago
Created attachment 8663511 [details] [diff] [review]
proposed patch(v1)
Attachment #8663511 - Flags: review?(Pidgeot18)
Comment on attachment 8663511 [details] [diff] [review]
proposed patch(v1)

Review of attachment 8663511 [details] [diff] [review]:
-----------------------------------------------------------------

What about suite/ and im/ ? r=philipp with the same changes applied there.
Attachment #8663511 - Flags: review?(Pidgeot18) → review+
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

2 years ago
Blocks: 1206609

Comment 5

2 years ago
Suite and IM have their own bugs, already landed.

Comment 6

2 years ago
I'll land this shortly.

Comment 7

2 years ago
Yes please, this makes the builds work again, I have tested it on try: https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=9ff44b0680d9

Comment 8

2 years ago
https://hg.mozilla.org/comm-central/rev/8c5af006b91c
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 44.0

Comment 9

2 years ago
Required for comm-aurora too.
(Assignee)

Comment 10

2 years ago
Comment on attachment 8663511 [details] [diff] [review]
proposed patch(v1)

[Approval Request Comment]
Regression caused by (bug #): 885982
User impact if declined: make pkg fails.
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky): none.
Attachment #8663511 - Flags: approval-comm-aurora?
Comment on attachment 8663511 [details] [diff] [review]
proposed patch(v1)

a+ for aurora, also for the other products if you haven't already gotten it.
Attachment #8663511 - Flags: approval-comm-aurora? → approval-comm-aurora+

Updated

2 years ago
Keywords: checkin-needed
Whiteboard: [checkin-needed comm-aurora]
https://hg.mozilla.org/releases/comm-aurora/rev/d0ddaf043bbc
status-thunderbird43: --- → fixed
status-thunderbird44: --- → fixed
Keywords: checkin-needed
Whiteboard: [checkin-needed comm-aurora]
You need to log in before you can comment on or make changes to this bug.