Closed Bug 1206654 Opened 7 years ago Closed 7 years ago

[Video]When user taps forward/backward or slide the progress slider to the end, the video displays black screen.

Categories

(Core :: Audio/Video: Playback, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

()

RESOLVED DUPLICATE of bug 1199809
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: huxiaoyan, Unassigned)

Details

(Keywords: regression, Whiteboard: [2.5-aries-test-run-2])

Attachments

(2 files)

[1.Description]:
[Aries KK v2.5][Flame KK v2.5][Video]When user plays a recording video in the video app, then slide the progress slider to the end, or quickly tap forward button until progress slider shows in the end of progress bar, the video displays black screen at the last frame.

Found at: 17:33~17:34
Attach: logcat_1734.txt and Aries KK_v2.5.3gp.

[2.Testing Steps]: 
1. Launch Camera app, record a video.
2. Launch Video app , select the video to play/pause.
3. Slide the progress slider to the end, or quickly tap forward button until progress slider shows in the end of progress bar.
4. If the bug can't be repro, repeat step 3.

[3.Expected Result]: 
Step3 & Step4. The correct video frame is shown without black.

[4.Actual Result]: 
Step3 & Step4. It displays black screen at the last frame.

[5.Reproduction build]: 
Device: Flame KK 2.2 (Unaffected) 
Build ID               20150920032503
Gaia Revision          95950c9d48ad2fc2da7686c2b133b750a99cd3da
Gaia Date              2015-09-18 09:55:13
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/38d6133e2416
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150920.065310
Firmware Date          Sun Sep 20 06:53:21 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5  (Affected) 
Build ID               20150920150205
Gaia Revision          e67d319d0854e32e23210784eb9c4e1b8a025adb
Gaia Date              2015-09-19 07:42:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ccd6b5f5e544c1d708849144943a776941bd3794
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150920.182952
Firmware Date          Sun Sep 20 18:30:04 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5  (Affected) 
Build ID               20150920050928
Gaia Revision          e67d319d0854e32e23210784eb9c4e1b8a025adb
Gaia Date              2015-09-19 07:42:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ccd6b5f5e544c1d708849144943a776941bd3794
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150920.042926
Firmware Date          Sun Sep 20 04:29:33 UTC 2015
Bootloader             s1

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free test
Attached video Aries KK_v2.5.3gp
Attached file logcat_1534.txt
[Blocking Requested - why for this release]:
I think the was resolved recently, but it looks like it came back. Major visual regression.
blocking-b2g: --- → 2.5?
QA Contact: lixia
Mozilla-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame KK 2.5
Build ID               20150818065331
Gaia Revision          d9d99f32762975a370f1abd34a3512bd6fe29111
Gaia Date              2015-08-17 16:47:27
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/9a5c40d6f4b36d953e128155b9845e7bdcdcae85
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150818.184156
Firmware Date          Tue Aug 18 18:42:07 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame KK 2.5
Build ID               20150818071235
Gaia Revision          d9d99f32762975a370f1abd34a3512bd6fe29111
Gaia Date              2015-08-17 16:47:27
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/560e0e0e3e8b5448fa91d36d4c9a9670ac5a0343
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150818.184156
Firmware Date          Tue Aug 18 18:42:07 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES NOT repro
Gaia Revision          d9d99f32762975a370f1abd34a3512bd6fe29111
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/9a5c40d6f4b36d953e128155b9845e7bdcdcae85

First Broken Gecko & Last Working Gaia - issue DOES repro
Gaia Revision          d9d99f32762975a370f1abd34a3512bd6fe29111
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/560e0e0e3e8b5448fa91d36d4c9a9670ac5a0343


Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9a5c40d6f4b36d953e128155b9845e7bdcdcae85&tochange=560e0e0e3e8b5448fa91d36d4c9a9670ac5a0343
QA Whiteboard: [MGSEI-Triage+]
Component: Gaia::Video → Audio/Video: Playback
Product: Firefox OS → Core
Blocks 2.5 with P2 priority.
blocking-b2g: 2.5? → 2.5+
Priority: -- → P2
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1199809
You need to log in before you can comment on or make changes to this bug.