Open Bug 1206736 Opened 5 years ago Updated 9 months ago

Firefox should not ask to save an incorrect Firefox Account credential

Categories

(Toolkit :: Password Manager: Site Compatibility, defect, P3)

defect

Tracking

()

REOPENED

People

(Reporter: rfeeley, Unassigned)

References

(Depends on 1 open bug, )

Details

Attachments

(1 file, 1 obsolete file)

Attached image save-incorrect.png
Currently Firefox prompts users to save logins (or just passwords) that are incorrect. Before asking, it should wait to see that an incorrect credentials message is not appearing for Firefox Accounts. See attached for current behaviour.
Summary: Firefox should not ask to save an incorrect Firefox Account credentials → Firefox should not ask to save an incorrect Firefox Account credential
Should we be asking to save credentials at all?  This looks pretty janky on Fennec.
Flags: needinfo?(rfeeley)
Attached image twitter-wrong-password.png (obsolete) —
To clarify, this bug is about general behaviour when the password is incorrect and is only using accounts.firefox.com as an example, rather than about any behaviour specific to accounts.firefox.com, right?

eg, here's the same issue for twitter.
oops, sorry, I see that the general case is bug 558178 and that this bug *is* specific to accounts.firefox.com
Attachment #8663955 - Attachment is obsolete: true
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 558178
This bug is related just to Firefox Accounts and should be handled. Currently we offer a pretty bad experience where it looks like the left hand doesn't know what the right hand is doing.
Status: RESOLVED → REOPENED
Flags: needinfo?(rfeeley)
Resolution: DUPLICATE → ---
Component: Password Manager → Password Manager: Site Compatibility
Depends on: 1296584
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.