[OSX] Default browser prompt - button text invisible

RESOLVED DUPLICATE of bug 1100401

Status

()

RESOLVED DUPLICATE of bug 1100401
3 years ago
2 years ago

People

(Reporter: agibson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8663722 [details]
default-popup.png

"Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:42.0) Gecko/20100101 Firefox/42.0"

STR:

1.) Start Firefox with a new profile
2.) When the /firstrun page opens, the default browser prompt is displayed.

Expected results:

The blue button to set firefox as my default browser should be visible.

Actual results:

The button is white and the text is invisible (see attachment). Only hovering over the button causes the styling to display correctly.
Hmm. Mstange fixed this in bug 1106906, but that was verified in the 36-38 cycles. So looks like this regressed.

I see this in release (40) and Nightly (43).
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Component: General → Widget: Cocoa
Flags: needinfo?(mstange)
Product: Firefox → Core
Resolution: --- → FIXED
(To be clear, I presume it's also in 41 and 42 but didn't specifically test.)
(And not sure how I managed to mark this fixed...)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → NEW
Created attachment 8718154 [details]
issue.png

I've been seeing this happen for a while now, usually happens when I'm using m-c and I've only ever seen it happen on OSX. Currently using:

* fx47 build id: 20160209030347
* Changeset: d1a54ae63da7

Updated

2 years ago
Flags: needinfo?(twalker)
Kamil, what version of Mac are you on?

This works for me on release Firefox 46.0.1 and latest Nightly 49.0a1, 20160531030258. Works in both Blue and Graphite system appearance themes on Mac 10.11.
Flags: needinfo?(twalker) → needinfo?(kjozwiak)
I think this happens if the main window is unfocused while the dialog appears, and then you switch to it.
(In reply to Markus Stange [:mstange] from comment #6)
> I think this happens if the main window is unfocused while the dialog
> appears, and then you switch to it.

Hmmm, I'm not sure how to reproduce that situation, as the dialog appears immediately on startup with a fresh profile.  No way top open another window to switch to/from while the Default browser dialog id present.
(In reply to Tracy Walker [:tracy] from comment #5)
> Kamil, what version of Mac are you on?
> 
> This works for me on release Firefox 46.0.1 and latest Nightly 49.0a1,
> 20160531030258. Works in both Blue and Graphite system appearance themes on
> Mac 10.11.

I'm currently using OSX 10.11.5 with the stock "Blue" system appearance theme and prefs. I'm still seeing this happening here and there on all the channels but it's really hard to reproduce. I've tried getting some STR a few times, but this happens every 20-30 installs or so, maybe even longer. Sometimes I don't see this issue for a few weeks, but it's definitely still occurring.
Flags: needinfo?(kjozwiak)
ok, P3 - (corner case, low occurrence and/or hard to reproduce)
Priority: -- → P3
Whiteboard: tpi:+

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago2 years ago
Flags: needinfo?(mstange)
Priority: P3 → --
Resolution: --- → DUPLICATE
Whiteboard: tpi:+
Duplicate of bug: 1100401
You need to log in before you can comment on or make changes to this bug.