External link with anchor opens with no anchor in Chrome, i.e. loses the destination point

RESOLVED WORKSFORME

Status

Thunderbird
Untriaged
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Alex, Unassigned)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.93 Safari/537.36

Steps to reproduce:

Recieved the notification with the link that contains anchor with parameters. Something like this:
http://host.com/client.html#~b~:0:11:abc:8:~p~:3:5

This is a single page application, and parameters actually build the specific state of the application. 
Clicked the link to open it in Chrome (default browser).


Actual results:

When I click that link from Thunderbird 38.2.0 it loads in the browser (Chrome 45.0.2454.93 m) without all the content after # character.
Like the following: http://host.com/client.html

In my case it means that the link is broken as app does not follow the specific init path.

I've tested links in emails in Thunderbird on regular html pages, like 
http://www.gwtproject.org/makinggwtbetter.html#community
or
http://docs.oracle.com/javase/7/docs/api/java/awt/datatransfer/Transferable.html#getTransferDataFlavors()

they also seem to drop everything after the #, including this character when clicked and opened in browser.


Expected results:

I expected the full link contents to be passed into the browser.
When clicked the same links from Gmail (in Chrome), everything works fine.
I tested this on Windows 8.1 with for a simple anchor case like
https://bugzilla.mozilla.org/show_bug.cgi?id=1107844#c6
and it was passed correctly/completely to Firefox Default browser.

However, there are lots of special characters in reporter's anchor so that might play a role:
http://host.com/client.html#~b~:0:11:abc:8:~p~:3:5
(Reporter)

Comment 2

3 years ago
Simpler links like http://www.gwtproject.org/makinggwtbetter.html#community won't pass too.
Then we need to find the exact difference (OS, browser etc.) between your case which fails and mine which works.
(Reporter)

Comment 4

3 years ago
Tested with Firefox 40.0.3, IE11, Edge on Win10 - all keep the after anchor parameters and do proper redirects.
Re-tested Chrome again - fails.
(Reporter)

Updated

3 years ago
Summary: External link with anchor opens with no anchor in browser, i.e. loses the destination point → External link with anchor opens with no anchor in Chrome, i.e. loses the destination point

Comment 5

2 years ago
Do you still see this with version 45?
These things tend to not be caused by Thunderbird.
Flags: needinfo?(a.volume)
Whiteboard: [closeme 2016-12-15]
(Reporter)

Comment 6

2 years ago
45.5.0 - passes links with anchors to Chrome with no noticeable side effects. All works fine, thank you!

Comment 7

2 years ago
Thanks for the update
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(a.volume)
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2016-12-15]
You need to log in before you can comment on or make changes to this bug.