Last Comment Bug 1206872 - [meta] Enable APZ on fennec on nightly builds
: [meta] Enable APZ on fennec on nightly builds
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: Graphics, Panning and Zooming (show other bugs)
: unspecified
: All Android
-- normal with 1 vote (vote)
: Firefox 45
Assigned To: (away until Feb21) Kartikaya Gupta (email:kats@mozilla.com)
: general
: (away until Feb21) Kartikaya Gupta (email:kats@mozilla.com)
Mentors:
Depends on: 1181703 1195553 1200397 1207748 1220925 1223296 1223433 1223434 1223436 1223486 1224325 1225287 1225508 1226320 1226394 1226872 1227636 1228216 1229118 1230522 1232377 1260905
Blocks: apz-fennec fennec-aboard-apz
  Show dependency treegraph
 
Reported: 2015-09-21 13:45 PDT by (away until Feb21) Kartikaya Gupta (email:kats@mozilla.com)
Modified: 2016-06-14 13:46 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Randall's patch (1.51 KB, patch)
2015-11-10 13:13 PST, (away until Feb21) Kartikaya Gupta (email:kats@mozilla.com)
no flags Details | Diff | Splinter Review
Patch (868 bytes, patch)
2015-11-11 09:49 PST, (away until Feb21) Kartikaya Gupta (email:kats@mozilla.com)
no flags Details | Diff | Splinter Review
0001-Bug-1206872-meta-Enable-APZ-on-fennec-on-nightly-builds-15112415-df71342.patch (1.61 KB, patch)
2015-11-24 15:15 PST, Randall Barker [:rbarker]
no flags Details | Diff | Splinter Review
Enable APZ on nightly builds (868 bytes, patch)
2015-11-27 07:56 PST, (away until Feb21) Kartikaya Gupta (email:kats@mozilla.com)
mark.finkle: review+
Details | Diff | Splinter Review

Description User image (away until Feb21) Kartikaya Gupta (email:kats@mozilla.com) 2015-09-21 13:45:48 PDT
This is a meta bug that tracks all the issues that need to be fixed before we can enable APZ on Fennec for nightly builds.
Comment 1 User image (away until Feb21) Kartikaya Gupta (email:kats@mozilla.com) 2015-11-10 13:13:36 PST
Created attachment 8685605 [details] [diff] [review]
Randall's patch

Randall had a patch in his queue to enable C++ APZ by default. Posting it here since this bug is eventually going to be used to land the patch that does this. However we'll need to update the patch so that it only does this for nightly.
Comment 2 User image (away until Feb21) Kartikaya Gupta (email:kats@mozilla.com) 2015-11-10 13:14:56 PST
(Actually it would also be better to put the MOZ_ANDROID_APZ=1 into mobile/android/confvars.sh rather than configure.in)
Comment 3 User image Mark Finkle (:mfinkle) (use needinfo?) 2015-11-11 08:37:55 PST
Comment on attachment 8685605 [details] [diff] [review]
Randall's patch

Should we also add something to confvars with a NIGHTLY_BUILD check?
Comment 4 User image (away until Feb21) Kartikaya Gupta (email:kats@mozilla.com) 2015-11-11 09:49:19 PST
Created attachment 8686145 [details] [diff] [review]
Patch

Yeah this is actually all that should be needed to flip it on. Seems to do the job locally at least.
Comment 5 User image Randall Barker [:rbarker] 2015-11-24 15:15:01 PST
Created attachment 8691619 [details] [diff] [review]
0001-Bug-1206872-meta-Enable-APZ-on-fennec-on-nightly-builds-15112415-df71342.patch
Comment 6 User image Timothy Nikkel (:tnikkel) 2015-11-26 18:52:23 PST
Bug 1224015 landed. So you can push this when ready.
Comment 7 User image (away until Feb21) Kartikaya Gupta (email:kats@mozilla.com) 2015-11-26 19:39:17 PST
We still need to do something about bug 1225508 - if you don't have any layout side fixes off the top of your head then I'm fine with landing the workaround that I have. I can do that tomorrow.
Comment 8 User image Timothy Nikkel (:tnikkel) 2015-11-26 19:46:36 PST
Oh yeah. Probably a fix along the lines of your "My bad attempt at fixing it in layout" patch is the way to go. I'll work on getting that landable. The workaround is reasonable so you can land that if you want to go ahead before that's ready.
Comment 9 User image Timothy Nikkel (:tnikkel) 2015-11-27 00:15:32 PST
This part

https://hg.mozilla.org/integration/mozilla-inbound/rev/0aa2e79b9252#l4.13

of bug 1224015 appears to have fixed bug 1225508 for me. This makes sense to me. (I tested with and without that hunk.) So I think you are good to land without the workaround.
Comment 10 User image (away until Feb21) Kartikaya Gupta (email:kats@mozilla.com) 2015-11-27 07:49:39 PST
(Moving discussion to bug 1225508)
Comment 11 User image (away until Feb21) Kartikaya Gupta (email:kats@mozilla.com) 2015-11-27 07:56:36 PST
Created attachment 8693007 [details] [diff] [review]
Enable APZ on nightly builds

I think we're ready to turn this on. Happy thanksgiving!
Comment 12 User image Mark Finkle (:mfinkle) (use needinfo?) 2015-11-28 11:42:08 PST
Comment on attachment 8693007 [details] [diff] [review]
Enable APZ on nightly builds

Great work getting to this point!
Comment 14 User image Carsten Book [:Tomcat] 2015-11-30 04:43:12 PST
https://hg.mozilla.org/mozilla-central/rev/cc0dde3ac2a8

Note You need to log in before you can comment on or make changes to this bug.