Sidebar text is overlapping 2 or so pixels into the splitter

NEW
Unassigned

Status

SeaMonkey
Sidebar
16 years ago
4 years ago

People

(Reporter: Tim Smith, Unassigned)

Tracking

({helpwanted, polish, regression})

Trunk
helpwanted, polish, regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

Attachments

(8 attachments)

(Reporter)

Description

16 years ago
If you adjust the size of the sidebar right up to the text of the sidebar there 
are a few pixels that overlap into the dividing bar that shouldn't be there
(Reporter)

Comment 1

16 years ago
Created attachment 65559 [details]
Picture showing pixel overlap
(Reporter)

Comment 2

16 years ago
Created attachment 65560 [details]
Picture showing pixel overlap
*** Bug 120703 has been marked as a duplicate of this bug. ***
*** Bug 120704 has been marked as a duplicate of this bug. ***
Tim Smith, please read our bug writing guidelines here:
http://www.mozilla.org/quality/bug-writing-guidelines.html

We are missing some important information to help us fix this bug, most notably
your Build ID.  Please include it on all bug reports you write.

Comment 6

16 years ago
I see this problem, win2000, build id 2002022603.

Steps to reproduce:

1. Use classic.
2. Open sidebar.
3. Adjust the width of the sidebar so that the sidebar titles don't fit.

Actual results: the text overlaps the dividing bar
Expected results: it shouldn't

This only appears in classic theme, modern is ok. So the component should
probably be Themes.

Comment 7

16 years ago
Created attachment 71960 [details]
a screenshot showing the problem (classic theme only)

Side bar title texts overlap the dividing bar.

Notice: the Tabs thingy looks weird too.

Comment 8

16 years ago
Created attachment 71979 [details]
"x", arrow and grippies overlap too

additional information: text isn't the only thing that overlaps. The arrow next
to the "Tabs" text, the "x" that closes the sidebar and the weird
grippy-thingies overlap too.

Comment 9

16 years ago
Created attachment 71981 [details]
a close-up (400% zoom)

...and if you look close enough, you'll notice they aren't really overlapping
the dividing bar, only the shadow (the dark gray and white pixel). But it's
still a bug.
confirmed on linux cvs 2002-03-25. platform,os->all
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac System 9.x → All
Hardware: Macintosh → All
Summary: Sidebar text is overlapping 2 or so pixels into the diving bar → Sidebar text is overlapping 2 or so pixels into the splitter

Updated

16 years ago
Whiteboard: DUPEME

Comment 11

16 years ago
*** Bug 133237 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
Over to Andreww for a look in classic.  Punt as needed.
Assignee: sgehani → andreww

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.1alpha

Comment 13

16 years ago
This is a regression.

This happened somewhere between 0.9.7 and 0.9.8 (probably a side-effect of
Hewitt's theme cleanup). 

I'll post some screen shots that prove this. Looks like a couple of hboxes and
vboxes were removed (the screen shots have DOM inspector windows open). Hope
this helps.

Comment 14

16 years ago
Created attachment 76758 [details]
0.9.7 doesn't have this problem...

Comment 15

16 years ago
Created attachment 76759 [details]
...but mozilla 0.9.8 and later do.

Comment 16

16 years ago
adding keywords polish, ui, regression and nominating for nsbeta1
Keywords: nsbeta1, polish, regression, ui

Comment 17

16 years ago
*** Bug 136159 has been marked as a duplicate of this bug. ***

Comment 18

16 years ago
While R.K.Aa noticed later that Bug 136159 is not a dupe at all (and changed its
status back to UNCONFIRMED) because it is about the personal toolbar/bookmarks
toolbar, this might still be related since the behaviour is much the same: 

Text (or icons) are printed over the right border of the element that contains
them and an additional pixel more over other elements (which is here the lighted
left side of the splitter).
This makes usually the 2 pixel mentioned here and in the other bug, when borders
are set to 1px.
With wider borders it is still printed over the border - and one pixel further
to the right. (see screenshots at Bug 136159).

Comment 19

16 years ago
*** Bug 141283 has been marked as a duplicate of this bug. ***

Comment 20

16 years ago
*** Bug 156513 has been marked as a duplicate of this bug. ***

Comment 21

15 years ago
Created attachment 102025 [details]
Overlapping statusbar

Sidebar overlaps status bar as well.
Classic theme. build 200210007
Marking future, this milestone is gone.

I will take a stab at this sometime...
Target Milestone: mozilla1.1alpha → Future

Comment 23

15 years ago
Nav triage team: nsbeta1-
Keywords: nsbeta1 → helpwanted, nsbeta1-

Comment 24

14 years ago
*** Bug 219128 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
Assignee: andreww → nobody
Status: ASSIGNED → NEW
QA Contact: sujay → sidebar
Target Milestone: Future → ---

Comment 25

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 26

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → EXPIRED

Updated

6 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: EXPIRED → ---
Still there (Linux, Classic theme).
Status: UNCONFIRMED → NEW
Ever confirmed: true
You need to log in before you can comment on or make changes to this bug.