Status

()

Core
CSS Parsing and Computation
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Brett Denny, Assigned: dbaron)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CSS1-2.1], URL)

(Reporter)

Description

16 years ago
My apologies, I'm not sure how to describe this bug - but looking at Eric
Meyer's css/edge page, when mouseovering the menu, the images that appear below
the menu seem to flicker.

Steps to reproduce:
1.  Visit the above URL
2.  Mouseover the menu items in the nav bar on the left side.

Expected results:
The images that appear below the menu items appear only once.

Actual results:
Images flash on and off a couple of times, causing a flickering during mouseover.
*** Bug 120701 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

16 years ago
I'm not really seeing a flickering (on a current Linux build), but maybe I'm not
understanding exactly what the problem is that you're describing.
(Reporter)

Comment 3

16 years ago
Do you see the images I'm referring to at least, under the nav menu at the left
of the screen?  My build is 2002011703 btw.
I can confirm this is 2002011803/Mac and I've seen it in Windows as well.  It
occurs with both the referenced URL and its companion,
http://www.meyerweb.com/eric/css/edge/popups/demo.html .  In detail, here's how
to reproduce the effect:

1. Pick one of the left-hand links.  I'll use "Other" here but any of them will
do the same basic thing.
2. Mouse into the blank space between the word "Other" and the border between
the links and the main section of the page.  Note the text that appears by using
creative CSS, and not Javascript.  Move the mouse around a little bit, so that
it stays in the blank area of the link.
3. Now slowly move the mouse from the blank area over the "r" in "Other". 
Notice that as you transit from the blank area to the letter, the popup text
disappear and then reappears.4. Move the mouse around inside the text a little
bit.  If you stay within the boundaries of the text, the popup text should
remain steady.
5. Move the mouse slowly to the left so it leaves the "O" and goes into the
blank area on the left.  The popup text should once again disappear and then
reappear.
6. Now move the mouse back and forth fairly quickly, but stay within the "Other"
link.  Watch the text popup flicker.

You can see this happen with any of the links.  With the popup images (the
demo2.html test URL) the images flicker exactly the same way.  With demo3.html
(in the directory http://www.meyerweb.com/eric/css/edge/popups/ ) you can watch
both text and images flicker in stereo.  It's keen!
Status: UNCONFIRMED → NEW
Ever confirmed: true
Confirming this bug and adding hyatt@netscape.com to the copy list.  (I showed
this bug to hyatt at one point.)
(Assignee)

Comment 6

16 years ago
On some of the links in http://www.meyerweb.com/eric/css/edge/popups/demo2.html
I'm actually not seing the image appear at *all* until I hit the text.  This
could be related to bug 5693.
Whiteboard: [CSS1-2.1]
The flickering seems to have stopped-- thanks to a tip from a reader at ToadNet,
I tested it in RC3 and Mozilla 1.0 and the popups were steady as a rock.  Anyone
want to guess how it got fixed, given the lack of activity in this bug?

Comment 8

16 years ago
WFM. No flickering with mozilla 1.0 on Win98.

Comment 9

15 years ago
WFM trunk 2002072718 on WinMe.
(Reporter)

Comment 10

15 years ago
WFM trunk 2002090104 - since this was a valid bug at one time and is not now,
changing resolution to FIXED.  I suppose WORKSFORME would apply too, though.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

15 years ago
If you don't know what fixed it, please use worksforme rather than fixed...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 12

15 years ago
...worksforme.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.